Webpack watcher does not get triggered on save

When running Webpack in watch mode in a terminal, I noticed that saving a file in my project does not trigger Webpack. It does work if I open VS Code and save the exact same file. That leads me to believe that it's restricted to Webstorm (I'm using 2019.1 on trial mode on Windows 10).

I tried the following with no luck:

  • Turning off 'safe write' option and restarting Webstorm
  • Doing a fresh clone of my repo in a different folder, running Webpack watch and saving a file
  • Opening a different Webpack project and tried triggering the watch with a different file
  • Removed Webstorm's file scope
  • Running Webpack from the integrated Webstorm terminal and outside the Webstorm terminal, even created a Run configuration that would start Webpack in watch mode
  • Just out of curiosity, running the TypeScript compiler in watch mode and tried saving a .ts file in the same project to trigger the TypeScript compiler. That also does not work.

At this point, I don't really know what to do, the usual answer I see (turning off 'safe write') doesn't seem to do anything.

Comment actions Permalink

Hi Elena,

I could recreate this issue in other projects as well, but you pointed me in the right direction: the shortcut combination that I used (Ctrl+S) was removed because I changed the key mapping.

It just had to be something small, I knew it!

Thanks for your patience and help.

Comment actions Permalink

WebStorm doesn't do anything special here - it just saves the file once you hit Ctrl+S (unless Safe write is on). Try checking file time stamp after saving the file - does it change? Also, do you store your project in a local folder, or on a shared network drive/dropbox/any drive that is encrypted or backed up, etc.?

Please recreate the issue and share your idea.log (Help | Show log in ...). Please don't paste it here, upload it to some file server and ;provide a link

Comment actions Permalink

Hi Elena, I checked the time stamp in Explorer and indeed: it does not change when I save the file in Webstorm (it does get changed when using VS Code). I can also see that the changes made in Webstorm are not being shown in VS Code, but it works the other way around.

My project is stored on my local hard drive, which is not being encrypted or anything.

I uploaded my log file here: https://www.dropbox.com/s/dafxnybv2n99cqy/idea.log?dl=0

Comment actions Permalink

No errors in log that look related (and you are the only user reporting such issues...)

Is the issue specific to certain project? Can you recreate it in a new project? Also, do you use a shortcut to save a file, or save it using File | Save All main menu?


Please sign in to leave a comment.