Issue with special chars in code


Hello,
I PhpStorm 2019.1.2 in some cases I use special char “ ” in my *.vue file

  • <i :class="'i_link '+getHeaderIcon('remove')"></i>&nbsp;Remove account

But in many cases saving code above and reopening this page later I see “&nbsp;” was replaced with “ ” and text above looks like

  • <i :class="'i_link '+getHeaderIcon('remove')"></i> Remove account

But trying remove letters before “Remove account ” terxt I see something like :

  • <i :class="'i_link '+getHeaderIcon('remove')"></i>&nbsRemove account

I dislike when “&nbsp;” automatically rendered into “ ”. The same issue I see in blade templates too.
But also not always. Is this some config option or what maybe some plugin controls this ?

Thanks!

4 comments

Hi there,

It would be good to see a screenshot of how it looks in your editor (using def theme) ... but quite likely it would be this option:

0

This option is on : https://imgur.com/a/WyYM9fe

Can it be some other option ?

0

Example : I use search function : https://imgur.com/a/VEvdHbo
and I see several ‘&nbsp;’

Doubleclick to open this page in editor https://imgur.com/a/TWEmrzU
and I DO NOT see ‘&nbsp;’

0

Yes, try disabling that option and restart IDE (or at least reopen files / project)

1

Please sign in to leave a comment.