13 comments
Comment actions Permalink

Please submit a support request attaching your logs bundle (Help | Compress Logs): https://intellij-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=66731

0
Comment actions Permalink

Confirm the problem. It seems like jet memory leak. You do nothing and memory consumption increases linearly. Ubuntu. Will send report with logs.

 

 

 

1
Comment actions Permalink

I can confirm the problem on macOS 10.14.5 as well after upgrading this morning: after a while the IDE becomes unresponsive and the low memory dialog pops up. The only solution for me so far is to close PhpStorm and reopen it. 

2
Comment actions Permalink

I can confirm this too on Ubuntu 18.04. 2019.2 just runs out of memory during indexing even if I allocate 4GB+ to the IDE so I've had to downgrade back to 2019.1 (first major problem I've ever had from an update). Has a ticket been created yet, I can't find one on youtrack?

2
Comment actions Permalink

Also confirmed same problem on Ubuntu 19.04 with PHPStorm 2019.2 installed via snap system.  The solution was the same - downgrade to 2019.1 and all was well.  

I'm happy to send along logs or other diagnostic data to help solve the issue - feel free to contact me. 

2
Comment actions Permalink

Same problem here. Phpstorm now is unusable. It just consumes all memory and freezes. On Ubuntu 19.4 ver 2019.2 since the last snap update.
Can't work, please help.

0
Comment actions Permalink

Just found that  the database & sql bundled plugin is eating all memory and processor, disable it, and it will go back to normal. Pls let me know if its only me?

1
Comment actions Permalink

Thanks for the update! Probably, this one could be related:

https://youtrack.jetbrains.com/issue/DBE-8694

In fact, it is marked as fixed, however, there is a comment with the report for the stable version as well.

Would it be possible to try a workaround with "database.snapshots.auto" registry key?

Also, I was wondering if anyone else from this thread may confirm that the issue happens when the Database plugin is used.

1
Comment actions Permalink

Same problem. 

0
Comment actions Permalink

@Vasiliy I can confirm toggling that registry key off fixes the problem for me.

0
Comment actions Permalink

I disabled the Database plugin as per Fernando's suggestion and so far no more memory problems for me. I didn't try the registry fix.

1
Comment actions Permalink

The same problem in Win10. I have noticed that this leak quite less when debugger is off.

0
Comment actions Permalink

DId exactly what @Roberto did. Can confirm disabling Database plugin helped. From around ~4G memory consumption now it's just ~2.5G. Haven't tried the registry fix yet also.

0

Please sign in to leave a comment.