Afte 2019.2 update, IntelliJ fails to start in Windows

Answered

I just applied the 2019.2 update on my Windows 10 (64 bit) machine. After the update, now the IDE fails to start. When I run the executable, there's no splash screen comin up. I checked in the Task Manager and I don't see any idaa process as well. It is not even showing any error message. It's like nothing happens when I run the idea.exe.

Help?

30 comments
Comment actions Permalink

Launch IDE via the .bat file (in IDEA_HOME/bin) from OS terminal and examine the output. What error is there?

0
Comment actions Permalink

Initial heap size set to a larger value than the maximum heap size - This is the error message.

0
Comment actions Permalink

Delete custom .vmoptions file or set lower value for the -Xmx parameter.

2
Comment actions Permalink

Thanks, after deleting the .vmptions file under config folder, now it starts.

0
Comment actions Permalink

Got same exact issue with PHPStorm after upgrading from 2019.1 to 2019.2 or even a clean install of 2019.2 on Windows. I ran the following tool from CMD:

C:\Program Files\JetBrains\PhpStorm 2019.2\bin\inspect.bat

And got this:

OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size

Updating or deleting "phpstorm64.exe.vmoptions" or "phpstorm.exe.vmoptions" in the same bin folder had no effect (and original -Xms and -Xmx values were correct anyway in those files).

Then I searched for other ".vmoptions" files, I found this one:

C:\Users\{user}\.PhpStorm2019.2\config\phpstorm64.exe.vmoptions

Note: replace {user} in the path with your own user account.

And for some reason it had wrong values of -Xms1024m and -Xmx990m (why should a clean install be like this!?). Fixed my issue by updating those values. -Xms has to be lower than -Xmx.

4
Comment actions Permalink

Had the same issue as Behrooz, but my values were -Xms2048m and -Xmx2024m. Replaced them with 1024 & 2048 and I was good to go. 

1
Comment actions Permalink

What are the max allowed values for  -Xms and -Xmx ?

0
Comment actions Permalink

@Spozdny,

Xms and Xmx are initial and maximum memory allocation pools. The theoretical memory limit of these values is about 16 Exabytes for 64-bit applications. If you have a lot of free RAM, you can allow IDE to have some more which will boost the performance while working with big files. But, of course, it's not mandatory - if things are fine now, let them be.

 

 

0
Comment actions Permalink

i am done everything possible even used the .BAT file still no joy

 

1
Comment actions Permalink

What's the error when you run it via idea.bat?

0
Comment actions Permalink

There was another copy of that file in C:\Users\<yourid>\.IntelliJIdea2019.2\config

I removed that one too and the IDE came up.

1
Comment actions Permalink

I believe the issue is that the upgrade overwrites the config file but for some reason doesn't keep the xmx value. So if you had setup your xms value to be at higher then 2gb (2048m) then it would fail on reload. The log file doesn't get written to and the only way to discover it is by running inspect.bat. I'm not sure why they copy all the other values other than this one but that was the issue for me. 

1
Comment actions Permalink

It is NOT already fixed.   That link specificly says "No Fix versions".   There is no fixed version currently avialalbe for down load.

   
1
Comment actions Permalink

Fixed in builds: 192.6257 means that the issue is fixed. No Fix versions is irrelevant.

The fix was delivered in 2019.2.1 RC: https://confluence.jetbrains.com/display/IDEADEV/IDEA+2019.2+EAP .

0
Comment actions Permalink

my installation of 2019.2 and 2019.2.1 does not have a config folder or any file with the name config in it... i did the patch update from within my intelliJ 2019.1.4 and now nothing works. i also tried downloading a clean copy of the 2.1 and still can't run the .bat or .exe

the 2.1 vmoptions are:

-server
-Xms128m
-Xmx512m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-XX:CICompilerCount=2
-Dsun.io.useCanonPrefixCache=false
-Djava.net.preferIPv4Stack=true
-Djdk.http.auth.tunneling.disabledSchemes=""
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-Djdk.attach.allowAttachSelf
-Dkotlinx.coroutines.debug=off

the idea.bat error is:

OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size

 

but my heap sizes are way under the 1024 number limit that was mentioned in a previous comment... any other thoughts?

0
Comment actions Permalink

You have a custom .vmoptions file, see https://intellij-support.jetbrains.com/hc/articles/206544869. In this file you have -Xmx value higher than -Xms which is not allowed.

0
Comment actions Permalink

I had this happen on both of my computers and it ended up being the kotlin plugin. I had to delete the kotlin folder in  the `C:\Users\<user>\.IntelliJIdea2019.2\config\plugins`.

0
Comment actions Permalink

Please, help. Windows 10 (x64), the idea of 2019.2 does not start. When you start idea.bat, I see a message: "Unexpected appearance: \JetBrains\IntelliJ.

0
Comment actions Permalink

Nullnos

Please wrap the command in the command line in quotation marks

before: 

\JetBrains/IntelliJ IDEA/2019.2/idea.bat

after: 

"/JetBrains/IntelliJ IDEA/2019.2/idea.bat" 

Alternatively, you can escape every space with backslash like that: 

/JetBrains/IntelliJ\ IDEA/2019.2/idea.bat

If it does not help, please provide a screenshot of the command line window with error. 

0
Comment actions Permalink

IDEA is installed in the folder: 
C:\Program Files (x86)\JetBrains\IntelliJ IDEA Community Edition 2019.2\bin

0
Comment actions Permalink

Please change directory to C:\Program Files (x86)\JetBrains\IntelliJ IDEA Community Edition 2019.2\bin and start idea.bat by typing ./idea.bat 

See this thread on how to run scripts with spaces in path in the command prompt:

https://superuser.com/a/432982

0
Comment actions Permalink

Konstantin-Annikov

Did:

But again I see this error: Unexpected appearance: \JetBrains\IntelliJ.

0
Comment actions Permalink

Did you modify idea.bat? Does the IDE reinstall help?

Does is start using idea64.exe instead of idea.bat?

0
Comment actions Permalink

No, I did not change the file.
Reinstallation, unfortunately, did not help.
When you start idea64.exe directly, nothing happens. Nothing at all.
Windows has recently been updated from version 7 to version 10. Maybe something went wrong.

0
Comment actions Permalink

After reinstalling it into the "Program files" folder (it was previously installed in Program files (x86), I managed to launch the idea through idea.bat, but in the usual way - a shortcut in the start menu or idea64.exe - idea does not start.

0
Comment actions Permalink

 i am getting this error when i try to start intellij, please look inti this problem!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

0
Comment actions Permalink

@doc.abeed please check this issue https://youtrack.jetbrains.com/issue/IDEABKL-7997 

>This is caused by Windows' Exploit protection, by the Mandatory ASLR, to be exact. This is off by default on Windows, but can be changed. If you want to keep Mandatory ASLR on by default, you will have to add an override for idea.exe or idea64.exe that disables Mandatory ASLR for the executable

And a workaround

>directions for turning the feature off globally or for a specific executable path are at https://docs.microsoft.com/en-us/windows/security/threat-protection/windows-defender-exploit-guard/customize-exploit-protection

0

Please sign in to leave a comment.