Very Strange Characters Display Bug (?)

Hello guys,
New Community Member here!
Name's Federico, really nice to meet you all.

I've been using a license obtained through registering my Uni account, for testing out your products and using them for some personal projects.
Let me say this: i really love them, they're very nice to use! GJ

I wish i would've been writing my first post here under better circumstances though... now let's get straight to the problem.

I use Toolbox to take care of automatically updating all Jetbrains software installed on my personal system.
Just this morning (about 3 hours ago) i was using PHPStorm and it was working really well (obviously :P).

I think Toolbox has automatically updated it to 2019.2 during lunch time,
since my PC and PHPStorm were both on/open at that time, and i was AFK.
I turned it off after lunchtime without checking anything (i was in a rush) by closing all open apps and shutting the system down (gracefully).
I then relocated from home to the library, started it all up again and opened PHPStorm.
It asked me what configuration options i wanted to import for version 2019.2 and i simply OK'd the default choice (can't even remember what it said).
In my mind: "Toolbox's so handy man!"

Let me tell you, the first view i saw immediately told me there was something way off.
Since i'm sure i didn't do anything "inadvisable", like turning abruptly off the power, forcing closure of the apps at shutdown, disconnecting storage archives without expelling them, i don't even know where to start looking to understand what might have been the cause of this bug, let alone actually solving it.

If you take a look at the screenshot i uploaded along this post, you can see that all markup and code of the project that was open at the time of me turning my pc off has now become unreadable. Even the terminal window looks like this, so PHPStorm is pretty much unusable at this point.




If you can't even tell what this markup is, i'm not surprised, i'll just say it REALLY shouldn't look like that xD
Just some Bootstrap 4 HTML btw.
I am a full stack developer and (somewhat) experienced Windows and OSX user, i've been using both OSes since i was 5, for almost 20 years now.
Can someone please help me understand how to make it work again?

Here are the system specs.
Operating System: Windows 10 Home 64-bit (10.0, Build 17134)
Language: Italian (Regional Setting: Italian)
System Model: ASUSTeK GL502VMK
BIOS: GL502VMK.308 (type: UEFI)
Processor: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz (8 CPUs), ~2.8GHz
Memory: 16384MB RAM
Storage: 256GB SSD + 1TB HDD
Graphics Card Model: NVIDIA GeForce GTX 1060
Graphics Dedicated Memory: 6052 MB

If you need additional information just ask, and thank you very much for your attention.

EDIT: I'm downgrading at the moment, and will be trying to update to 2019.2 again when finished. Fingers crossed :)

5 comments
Comment actions Permalink

Please install 2019.2 alongside with 2019.1 so that we could chek things together.

What encoding for this file does it show you in the status bar? http://prntscr.com/ok2h0v

Also, please share a screenshot of Settings | Editor | File Encodings.

1
Comment actions Permalink

To me it looks like some font issue.

In the past I have seen few threads here (over years) where italic font would display gibberish while normal/straight one would be OK. Here it seems to be other way around...

0
Comment actions Permalink

Hey there guys, sorry for the delay but i was finishing a personal project using 2019.1.3 (the latest stable build for my system).


@Eugene:
I'm currently installing 2019.2 alongside 2019.1 (i had previously checked the "Keep only the latest version" option, now unchecked it).


Here's everything you asked:

 

@Andriy:
I appreciate the input.
I've guessed too that it might be a font issue, and i've seen while searching for similar problems before creating this thread that during the years many font issues have been reported, but i actually haven't found anything quite like this.

I tried changing font, but it didn't work, so i guess this probably isn't a font-related issue. I bet encoding-related settings is where we'll find the cause of the problem...

0
Comment actions Permalink

Looks like, you have a Material UI plugin installed. Would it be possible to temporarily disable it, restart the IDE and check if the issue is still there?

1
Comment actions Permalink

That worked, thanks a lot Vasiliy!
However, i think i'll stay with the Material UI plugin and version 2019.1.3 and wait for the day it will work with 2019.2
Have a nice week :)

0

Please sign in to leave a comment.