Version Control view incorrectly (?) honors Settings->Editor->File Types->Ignore files and folders

Answered

I want to hide the .idea folder in my Project view. There's nothing in there I should be editing directly.

But when I add .idea to the list in Settings->Editor->File Types->Ignore files and folders, then any changes to files in .idea are then excluded from the Version Control view. 

We commit some, but not all, of the contents of .idea to git, but when these changes are being hidden from the Version Control view, they often don't get committed when they should, and then I get the dreaded "uncommitted changes" when trying to switch branches and pull.

Why does the Version Control view do this? In my opinion the contents of the Version Control view should honor only .gitignore and Settings->Version Control->Ignored Files. The Version Control view should not care what is shown or hidden in the project structure.

 

 

1 comment
Comment actions Permalink

> Why does the Version Control view do this?

The thing is that IDE relies on VFS (virtual file system) to show files and its content, and exclusion via Settings->Editor->File Types->Ignore files and folders prevents VFS from loading the file at all. It is not only about Project View.

Here is the request to change Version Control tab behavior - https://youtrack.jetbrains.com/issue/IDEA-180523

> I want to hide the .idea folder in my Project view

There are other ways to do so. E.g., mark .idea as excluded and disable the Show Excluded Files option of the Project tree view

1

Please sign in to leave a comment.