jump to source not showing in the run window.


When I run maven compile from the the maven window, I expect my compilation errors to be in the run window with hyperlinks that take to the compilation error in the source file.  Since upgrade to version 2019.2 I can't get this functionality anymore.  The screen shot below is where I just reproduced the error and you can see there are no hyperlinks




You should be able to click on the errors in the tree on the left.

To get the old behavior disable the build delegation:


It's still not working even after I disable build delegation.  To set things straight, it was already disable on my IDE. 



Run using IntelliJ IDEA Application configuration with Build action in Before Launch.


I don't understand what you mean by "Run using IntelliJ IDEA Application configuration with Build action in Before Launch.".  May you please show me the step of what I need to do. 


I too am suffering from this issue since upgrading to 2019.2.

Build delegation is already disabled.

I don't have a suitable configuration in Run/Debug configurations in order to set the Before launch option.  I'm not trying to run anything; I'm just trying to build it.

I'm using Maven to build my modules and then run the associated tests, all via the Maven 'test' lifecycle.

This used to work ok in 2019.1 and now it does not work in 2019.2.  My observation here is that I shouldn't need to be making changes in order to get this to work again in 2019.2.  If such changes are required, the upgrade process should have automatically applied them so that the behaviour before is the same as the behaviour after.

How do I get 'Jump to Source' to work again?



Hi David,

We have found an issue with Maven build tool window and the fix is on the way. I hope the fix will make it into 2019.2.2 version update. You can follow the https://youtrack.jetbrains.com/issue/IDEA-220999 for updates to be notified when and in which version it will be fixed.


Thanks for the update.  Looking forward to 2019.2.2


After update to 2019.3.1 (Ultimate Edition) issue is still there. 

Steps to reproduce:

* run any Maven target

* try to jump to source on any file (context menu is greyed out, hotkey is not working)


Works here:

Can you zip and provide a sample project where it fails and screenshots showing the problem? For uploading you can use ftp://ftp.intellij.net/.uploads / https://uploads.services.jetbrains.com or any file sharing service.


Andrey, not sure about the reason, but it after some time issue has gone.


Can you please comment on the "Jump to Source" behavior? It does work for some messages and doesn't work for the others.

Notably, if the message comes from the Java compiler, like:

[ERROR] /src/..../SomeFile.java:[3,5] 

it correctly recognizes it as an error and "Jump to Source" works. If, however, you have something from Scala compiler:

[ERROR] [Error] /src/.../SomeFile.scala:13: expected

It does not recognize it as an error and "Jump to Source" is grayed out.

Note that messages like the following don't work either (I just changed the file extension):

[ERROR] /src/..../SomeFile.scala:[3,5] 

Is this feature relying on the files being exclusively java? Is this expected behavior? I looked at DEA-220999 but still can't figure it out...

Thank you!

My setup:

IntelliJ IDEA 2019.3.4 (Community Edition)
Build #IC-193.6911.18, built on March 17, 2020

P.S.: My "ideal" state of affairs would be recognizing the qualified paths in the right-hand side as links. Probably second best would be recognizing any messages in the tree that are qualified paths as "Jump to Source" targets regardless of the extension.



Try to use EAP version of IntelliJ IDEA, where the similar issue with Scala has been fixed. 

If the issue is still here, please share a zipped project sample (or link to GitHub) where this could be reproduced. 

Normally, "Jump to source" should work in Scala. 



I tried the EAP, thanks. Unfortunately, as the "Jump to Source" feature goes, I think it got worse. Now I can only see the goal failures in the tree, no individual errors.

Example output from Maven:

[ERROR] /src/.../Whatever.scala:23: whatever

I looked at https://github.com/JetBrains/intellij-community/blob/master/plugins/maven/src/main/java/org/jetbrains/idea/maven/externalSystemIntegration/output/parsers/BuildErrorNotification.java implementation and I don't see any Scala support in the parsers package - Just Java and Kotlin. Am I looking at wrong place?

Thank you!


> I don't see any Scala support

Scala support is implemented in Scala plugin. Do you have it installed? 


Yes, I do - 2019.3.27. Maven is using net.alchim31.maven:scala-maven-plugin:4.3.1 with scala version 2.11.8. I guess project example is the way to go.


Please sign in to leave a comment.