DataGrip 2019.2 lost all data sources after update.

Answered

After update to 2019.2 all datasources are disappeared.

Is it any way to do automatically without copying all the settings manually? 

21 comments
Comment actions Permalink

Yes, they might be still n the old folder of 2019.1. Just open the project you were working in 2019.1.

Default project is supposed to be stored in

MacOs:

~/Library/Preferences/<PRODUCT><VERSION>/Projects

Windows:

SYSTEM DRIVE>\Users\<USER ACCOUNT NAME>\.<PRODUCT><VERSION>\Projects

Did you update from the IDE? I suggets you to use ToolBox App: https://www.jetbrains.com/toolbox/app/

0
Comment actions Permalink

I know that, the question is why they cannot be moved with Cloud Sync? How the Cloud Sync flow should be used?

0
Comment actions Permalink

I use ToolBox App on Ubuntu 18.04 to update DataGrip 2019.1 -> 2019.3 and the software have again lost whole configuration (datasouces, connections). Yes, configs are still in the ~/.DataGrip2019.1 directory, but I have to move it manually.

I think there is something wrong with options on first launch after update:

We can either sync with Account settings (plugins) or look up for local settings, but in 21th century I use the product on at least 3 devices for the same connections.

So my question is: Is there some easy way to import connections from previous versions, while keeping sync with Account?  

0
Comment actions Permalink

I use ToolBox + Intellij Idea. Current version is 2020.1.2. Just now I noticed that all database connections disappeared (oh no. I hope I can recover them)

1. How to find the version since when they disappeared?

2. How to restore them (if possible)?

3. How to make it not happen again?

1
Comment actions Permalink

I reverted version, seems like DB credentials are are stored for each version independently.

For now, use password management tool to keep connection configs.

0
Comment actions Permalink

After update to 2020.2 all lost data sources re-appeared!

Does anyone know the relevant issue url?

 

 

1
Comment actions Permalink

Ivan, can we ask for logs? 
Please send'em to datagrip@jetbrains.com 

0
Comment actions Permalink

Maxim,

Do you mean downgrade to 2020.1 first? I'm using Intellij Idea Ultimate (if it changes anything).

0
Comment actions Permalink

No, just your current ones

0
Comment actions Permalink

Any solutions to this issue?

2
Comment actions Permalink

It's hard to locate the problem, but we hope that we've found it and we are in the process of fixing it.

Anyway, even if the data sources are lost they can be recovered as written above.

0
Comment actions Permalink

All my data sources disappeared after I upgraded. I closed Pycharm and relaunched and they came back. So it may just be a matter of a restart.

0
Comment actions Permalink

Update DataGrip from 2020.1.5 to 2020.2.3 in the Toolbox.

-> All my data sources disappeared
-> Roll back to 2020.1.5
-> data sources came back

-> then I exported the settings (settings.zip, all components)
-> again upgrade to 2020.2.3
-> import settings.zip, I had to restart
-> but nothing happend, no datasoures appears

-> downgrade to 2020.1.5 -> all ok

Any solutions?

 

 

0
Comment actions Permalink

Just upgraded to 2020.3.1 and lost all my database connections AGAIN.  This happens a lot more recently.  Please fix this, or give us a longer term storage option outside of IntelliJ if you insist on not keeping them.

0
Comment actions Permalink

Got same problem here. I did not loose all database connections after update but they somehow got overwritten with older version.

0
Comment actions Permalink

Quite simply, an awful experience. Horrible. Very unlike Jetbrains. This should definitely be fixed. 

4
Comment actions Permalink

I lost my settings.
After updating, settings are not fully transferred to a new version directory.
Update was made by toolbox but when making some free space I've deleted old DataGrip2019 directory.
This is not good approach to keep settings in random places of older versions that were updated like 2 years ago! Please do not treat db connections configs like projects with source code that are backed up by git, or make this explicit.
I have to fix this manually, you can check if there is some dependency to old project directory by file>open recent>manage projects. :)

2
Comment actions Permalink

Just had this issue within Rider. Restart of the computer helped. Restart of the IDE did nothing.

Not the first time I notice this behaviour. This time it seems to have happened after an update I made to dotMemory and dotTrace from Toolbox.

0
Comment actions Permalink

I have to fix this manually, you can check if there is some dependency to old project directory by file>open recent>manage projects. :)

Thank you Artur Skii, that saved me from a lot of hassle :)

0
Comment actions Permalink

Hi there,

I also lost all database connections and scratch-files after the DataGrip 2020->2021 update.
Thanks to the comments above, I found out how to restore the data without downgrading the IDE.

1. Go to File -> Manage IDE settings -> Import settings
2. Select the folder with the previous version of DataGrip. For me, it was ~/Library/Application Support/JetBrains/DataGrip2020.3
3. Click "Open." The IDE will restart, and all the data sources and scratches should be restored

I hope it helps

1
Comment actions Permalink

Thanks Daniil Gusev it's works. I have 2021.2.1.

0

Please sign in to leave a comment.