Files not auto synchronising

Answered

Since updating to the latest version of Idea (2019.2) files no longer auto synchronise. if I make a change to fix, for example, a compilation error in my coder and then attempt to run it; the code still doesn't compile - even though the code is properly fixed. If, however, I then go to File>Synchronize it will then compile properly and "take notice" of the changes in my code.

12 comments
Comment actions Permalink

Do you make the changes outside of IntelliJ IDEA in some other editor?

What are you Synchronize settings? What file type do you edit?

0
Comment actions Permalink

Only edited in Idea and they are Java files.

Here are my settings:

It also seems to pick up the changes if I run Build (CTRL + F9) before running - but I never had to do that before...

0
Comment actions Permalink

Do you have Build action in the Before Launch section of the Run/Debug configuration?

0
Comment actions Permalink

Is it a Gradle project? Do you have build/run actions delegated to Gradle? http://mrhaki.blogspot.com/2016/11/gradle-goodness-delegate-build-and-run.html.

0
Comment actions Permalink

It is a gradle project, but I haven't changed any of the settings since before upgrading the IDE. Before the upgrade it was working as expected, but now I have this problem. My settings don't look exactly the same as in the link you gave, but pretty similar:

0
Comment actions Permalink

If you enable File | Settings | Editor | General | Editor Tabs | Appearance | Mark Modified (*) option, do you see the file saved when the run configuration is started?

0
Comment actions Permalink

Difficult to see how that bug may be related - but I'm sure you know best! Zip of logs here: https://www.dropbox.com/s/6gf0lkiupba4nr5/idea-logs-20190725-202710.zip?dl=0

0
Comment actions Permalink

Does the issue persist if you disable Android plug-in?

0
Comment actions Permalink

No - that seems to fix it. At least in the short term. I do require Android support so...

0

Please sign in to leave a comment.