Run applicaiton always runs un gradle with two console tabs in the Run / Debug pane

Answered

Hi, I have an issue on my desktop Intellij idea 2019.2 that's been around for a while. It started spontaneously, a while back and I have not been able to figure out how to fix it.  I do not have this problem on my laptop with the same version of Idea or codebase. I expect there is a configuration option somewhere that's wrong but I don't know what it is.

When I run my applicaiton in Idea, instead of just running it like it used to, now it always seems to run via gradle. This means that if there are errors they show up as a failed gradle build and I do not see all of the compiler output as cleanly... If it does run, then in the run (or debug) console tabs I get two tabs popping up, as if two different applications are running but one seems to show gradle output and the other the console of my application. I need it to go back to just running the application the way it was before.

Here's the tab with my running log, which is all I want to see:

 

But this tab pops up too. When I have a breakpoint  I have issues with these two tabs, and sometimes I have up to 5 instances of my app running at once so I end up with 10 tabs.

Run configuration:

 

How can I fix this?
Thanks,
Troy

4 comments
Comment actions Permalink

This was an intentional change in IDEA.

See https://youtrack.jetbrains.com/issue/IDEA-152972 and https://youtrack.jetbrains.com/issue/IDEA-200694

Don't ask me why there's still no progress on this.

0
Comment actions Permalink

Thankyou for the comment Stephen, yes this is really becoming an issue for me. I don't understand why they've moved in this direction. Strangely, I don't seem to have this issue on my laptop though, which has the same version of Idea on it. But I do most of my development on my desktop and this is really killing my productivity and causing me lots of issues. I don't recall what version of intellij I first encountered this on, but when it first happend I reverted back and it went away, but then I upgraded again... I might have to go back to 2018.x again.

0
Comment actions Permalink

>Strangely, I don't seem to have this issue on my laptop though

You will get two tabs if you are using Gradle for running the configuration. E.g. when Settings (Preferences on macOS) | Build, Execution, Deployment | Build Tools | Gradle | Build and run using is set to Gradle (2019.2 version) or Settings (Preferences on macOS) | Build, Execution, Deployment | Build Tools | Gradle | Runner | Delegate IDE build/run actions to Gradle is enabled (2019.1 version).

1
Comment actions Permalink

Thankyou Andrey, changing that to Idea reverts it to the expected behavior. Much better!

0

Please sign in to leave a comment.