Font Line spacing change in 2019.2?

Answered

I just updated and thought "the text in my editor looks different somehow".

After playing around, I'm pretty sure the line spacing has changed from 1.0 to 1.2.

Does anyone know if this is the case?

19 comments
Comment actions Permalink

Yes, it's by design, please see https://youtrack.jetbrains.com/issue/IDEA-219016 for details.

0
Comment actions Permalink

Serge,

It was easy enough to go to Settings -> Editor -> Font -> Line spacing and change it back to 1.0. That fixed what's going on in my code. However, this doesn't change it for, for example, the Run/Debug output pane where I still see increased leading. I am more interested in screen real estate than I am in whatever are the interests of those who decided to change leading to 1.2.

How can I change leading in the output?

0
Comment actions Permalink

You can change the console font settings here:

1
Comment actions Permalink

Is it possible to get the very small line-spacing back that was used in the console before the update?  
With this change ASCII tables look bad, even when decreasing the line-spacing to 0.6, which is the lowest line-spacing that can be set.

Edit: I have now tried this with all pre-installed fonts and it all looks the same.

0
Comment actions Permalink

Hello,

Previously 1.0 spacing was used. Now it's 1.2. Switching to 1.0 should help. Where did you change spacing?

0
Comment actions Permalink

I am very sorry for reporting this here. I Installed an older version of the IDE with toolbox just to make sure and found that it looks the same. So please disregard my previous commend.I originally made my post, because I vividly remember seeing it without spaces between the lines at some point, but now I cannot be sure anymore.  

Again, I am sorry if I caused any inconvenience.

 

0
Comment actions Permalink

No problem. Probably different font was used previously.

0
Comment actions Permalink

Hmm.. mine didn't work, changing from 1.2 to 1.0 or 0.9, the preview works, but the editor didn't change, even after restarting the intellij

1
Comment actions Permalink

nevermind, there's other line spacing configuration that should be changed instead of Editor > Font XD

0
Comment actions Permalink

please tell me, has anything else changed in the font relations in this version? my eyes do not deceive me, something wrong.
I use your ide primarily because of the fonts!
what do I need to do to get my old fonts back?

0
Comment actions Permalink

@Marat,

Check the font itself. In 2019.1.3 it was set to Monospaced 12/1.0. 

1
Comment actions Permalink

Changing the line spacing to 1.0 alone, did not help me either. Changing the font to Monospaced helped resolving this issue for me.

 

0
Comment actions Permalink

Hello.

What about the spacing in the Test results? I'm pretty sure this has changed and I can't find a way to change the spacing of it:

0
Comment actions Permalink

Petr Rastegaev nope, It changes the font in the console but does not affect the testing list

0
Comment actions Permalink

This problem appeared quite a long time ago. You can find mentions of this issue in posts across Internet dated 2018.

It's reproduced in all JetBrains IDEs on macOS, Linux, Windows and different machines, physical or virtual.

Sounds funny, but when I change line spacing|height from your "default" 1.2 to 1.0 there should be visible difference and I expect it to be exactly 20% from 1.0. There must be no visual difference at all, when line spacing|height of the "Editor" is changed to be equal to the line spacing|height of "Console".

I am your customer and I love your products, but tool windows using this "Console Font" setting, like "Terminal", especially "Terminal"(!), became unusable.

0
Comment actions Permalink

Yes, it describes the same issue. See https://youtrack.jetbrains.com/issue/IDEA-201379 too.

0
Comment actions Permalink

P.S. I remember it was one of the first updates 2018, where sth. went wrong with "Line Spacing" setting of "Console Font".

0

Please sign in to leave a comment.