Debugging python in maya - worked with pyCharm 2018, but not 2019.2

As the title says.  I'm using the MayaCharm plugin.  As with the previous pyCharm version, I run this on the maya side:

import maya.cmds as cmds
if not cmds.commandPort(':4434', q=True):

And then click on the green bug in PyCharm.  Here's the output from PyCharm/MayaCharm:

"C:\Program Files\Autodesk\Maya2018\bin\mayapy.exe" "C:\Program Files\JetBrains\PyCharm\helpers\pydev\" --multiproc --qt-support=auto --client --port 61289 --file D:/p4/wwe2k/main/Art/Tools/maya/scripts/MayaPython/vcCloth/
Traceback (most recent call last):
File "C:\Program Files\JetBrains\PyCharm\helpers\pydev\", line 20, in <module>
from _pydevd_bundle.pydevd_constants import IS_JYTH_LESS25, IS_PYCHARM, get_thread_id, get_current_thread_id, \
File "C:\Program Files\JetBrains\PyCharm\helpers\pydev\_pydevd_bundle\", line 179, in <module>
from _pydev_imps._pydev_saved_modules import thread
File "C:\Program Files\JetBrains\PyCharm\helpers\pydev\_pydev_imps\", line 15, in <module>
import xmlrpclib
File "C:\Program Files\Autodesk\Maya2018\bin\\", line 145, in <module>
File "C:\Program Files\Autodesk\Maya2018\bin\\", line 80, in <module>
File "C:\Program Files\Autodesk\Maya2018\bin\\", line 6, in <module>
File "C:\Program Files\Autodesk\Maya2018\bin\\", line 32, in <module>
File "D:\p4\wwe2k\main\Art\Tools\maya\scripts\MayaPython\vcCloth\", line 36, in <module>
ART_BIN_PATH = os.path.join( common.getToolsMayaRoot(), "bin" )
File "C:\Program Files\Autodesk\Maya2018\bin\\", line 65, in join
File "C:\Program Files\Autodesk\Maya2018\bin\\", line 115, in splitdrive
TypeError: object of type 'NoneType' has no len()

Process finished with exit code 1

Comment actions Permalink

Hi, MayaCharm is a third-party plugin so you might want to report the issue to the plugin maintainer instead. Also the stack trace is showing the file belonging to Maya2018

Does the issue happen when you run in non-debug mode?


Comment actions Permalink

No problem when not debugging.  Thanks, I'll try MayaCharm.


Please sign in to leave a comment.