DataGrip 2019.2 RC Can't view External Tables in Redshift




Since upgrading to 2019.2 I can't seem to view any Redshift external tables. I can only see them in the schema selector accessed by using the inline text on the Database Explorer (not in the connection properties schema selector), and when I select them in the aforementioned schema selector nothing happens and they are unselected when I next open it.

I've also just tried selecting all schemas and they still do not appear.


Selected them manually:

Next time I open it, they are unselected:


With "All Schemas" selected, they are just unchecked:


And the schema selector in Connection Properties, they aren't shown at all:



I can't see anything suspect in the logs, apart from the following error on initial connection (fyi I'm connecting to a external server not localhost) - i'm guessing its not related but just incase:

2019-08-08 10:25:22,071 [175288279] INFO - ution.rmi.RemoteProcessSupport - version: PostgreSQL 8.0.2 on i686-pc-linux-gnu, compiled by GCC gcc (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3), Redshift 1.0.9003
2019-08-08 10:25:22,072 [175288280] INFO - ution.rmi.RemoteProcessSupport - Detected: REDSHIFT 1.0.9003
2019-08-08 10:25:24,186 [175290394] INFO - ution.rmi.RemoteProcessSupport - Terminating: 18855/RemoteDriverImple5cf33a6
2019-08-08 10:25:24,186 [175290394] INFO - ution.rmi.RemoteProcessSupport - Terminating: 18855/RemoteDriverImple5cf33a6
2019-08-08 10:25:24,247 [175290455] INFO - ution.rmi.RemoteProcessSupport - Process finished with exit code -1
2019-08-08 10:25:29,550 [175295758] INFO - nSession$CountedThreadExecutor - DbSrcWriter stopped
2019-08-08 10:25:30,244 [175296452] WARN - lij.database.util.ErrorHandler - Connection refused to host:; nested exception is: Connection refused: connect
java.rmi.ConnectException: Connection refused to host:; nested exception is: Connection refused: connect
at java.rmi/sun.rmi.transport.tcp.TCPEndpoint.newSocket(
at java.rmi/sun.rmi.transport.tcp.TCPChannel.createConnection(
at java.rmi/sun.rmi.transport.tcp.TCPChannel.newConnection(
at java.rmi/sun.rmi.server.UnicastRef.invoke(
at java.rmi/java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(
at java.rmi/java.rmi.server.RemoteObjectInvocationHandler.invoke(
at com.sun.proxy.$Proxy138.disconnect(Unknown Source)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
at java.base/java.lang.reflect.Method.invoke(
at com.intellij.execution.rmi.RemoteUtil.invokeRemote(
at com.intellij.execution.rmi.RemoteUtil.access$200(
at com.intellij.execution.rmi.RemoteUtil$RemoteInvocationHandler.invoke(
at com.sun.proxy.$Proxy139.disconnect(Unknown Source)
at com.intellij.database.dialects.base.introspector.AuditFacade.disconnect(AuditFacade.kt:52)
at org.jetbrains.dekaf.intermediate.AdaptIntermediateFacade.disconnect(
at org.jetbrains.dekaf.core.BaseFacade.disconnect(
at com.intellij.database.dialects.base.introspector.BaseIntrospector.detachFromDB(BaseIntrospector.kt:147)
at com.intellij.database.dataSource.DatabaseModelLoader$IntrospectionSession.lambda$null$2(
at com.intellij.database.dataSource.DatabaseModelLoader$IntrospectionSession.withFacade(
at com.intellij.database.dataSource.DatabaseModelLoader$IntrospectionSession.lambda$introspect$3(
at com.intellij.database.dataSource.DataSourceSyncManager.lambda$null$0(
at com.intellij.database.console.session.SessionsUtil$function$1.invoke(SessionsUtil.kt:16)
at com.intellij.database.console.session.DatabaseSessionManager$Facade.compute(DatabaseSessionManager.kt:331)
at com.intellij.database.console.session.DatabaseSessionManager$Facade.runSync(DatabaseSessionManager.kt:266)
at com.intellij.database.dataSource.DataSourceSyncManager.lambda$static$1(
at com.intellij.database.dataSource.DataSourceSyncManager$SyncProcessor$1.perform(
at com.intellij.database.dataSource.DatabaseModelLoader$IntrospectionSession.introspect(
at com.intellij.database.dataSource.DatabaseModelLoader$IntrospectionSession.lambda$run$1(
at com.intellij.database.dataSource.LocalDataSource.performBatch(
at com.intellij.database.dataSource.DatabaseModelLoader$
at com.intellij.database.dataSource.DataSourceSyncManager$SyncProcessor.performSync(
at java.base/java.util.concurrent.CompletableFuture$
at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(
at com.intellij.database.dataSource.AsyncUtil.underProgress(
at com.intellij.database.dataSource.AsyncUtil.lambda$null$2(
at com.intellij.openapi.application.impl.ApplicationImpl$
at java.base/java.util.concurrent.Executors$
at java.base/
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/
Caused by: Connection refused: connect
at java.base/ Method)
at java.base/
at java.base/
at java.base/
at java.base/
at java.base/
at java.base/
at java.base/
at java.base/<init>(
at java.base/<init>(
at java.rmi/sun.rmi.transport.tcp.TCPDirectSocketFactory.createSocket(
at java.rmi/sun.rmi.transport.tcp.TCPEndpoint.newSocket(
... 44 more
2019-08-08 10:25:46,259 [175312467] INFO - .diagnostic.PerformanceWatcher - Pushing properties took 1ms; general responsiveness: ok; EDT responsiveness: ok


Exactly the same here. I am not able to show the Redshift external tables with 2019.2 version. I just acquired the license to work on Redshift environments and just now I find this issue. Any help will be appreciated.


Expect the fix in 2019.2.2


I have a similar issue in 2019.2.5.

If "all schemas" are selected for the connection then new external schemas are added to the database and the connection was refreshed, those new schemas are not visible in the explorer. They are however visible under "Schemas" in the connection properties.
Only way to make them visible in the explorer is to manually select them. "All schemas" does not seem to work


Ivan, we've fixed it. expect in the closest update.


I have the same problem in the current version: 2021.1.3 - macOS (dmg)


External schemas are under Database objects in tree:


I am on DataGrip version 2021.2.4. I am able to see the external schemas but not the tables within the external schemas. Is there a configuration I am missing that should enable viewing the list of tables within the external schemas? Even in the screenshot above the athena_test doesn't display any tables in the dropdown. 



Could you file an issue in DataGrip bug tracker and attach IDE, SQL and logs produced by Prepare Introspector Diagnostics action?


I can't reproduce the issue.


Please sign in to leave a comment.