DataGrip 2019.2.1 showing underscore for thousands separator in editor

Completed

After updating to 2019.2.1, when I load a console file into my editor, all numeric values have a thousands separator in them, i.e. 104288597 displays as 104_288_597. The queries run correctly and when I click on the value, the underscores disappear. Is there a setting for this behavior?

6 comments
Comment actions Permalink

According to https://youtrack.jetbrains.com/issue/DBE-8811 you can disable it in editor settings: File|Settings -> Editor|General|Code Folding|Long SQL Literals

3
Comment actions Permalink

Thank you for finding that for me! I searched around but couldn't find the setting.

0
Comment actions Permalink

Don't like it either, and "Code Folding" -> "Long SQL Literals" is not very intuitive for that setting.

0
Comment actions Permalink

Thanks for the help, Furiia!

0
Comment actions Permalink

The whole feature seems not thought to an end. If they would put special unqiue design or folding-technics around it and between the characters, it could maybe help. (especially with an hotkey to toggle on and off) But like now, especially with a underscore (you shouldn't use similar characters developers are using) it just could be misinterpret as invalid code after format-options or invalid information.

0
Comment actions Permalink

The key stroke combination Ctrl + . when my cursor is in the number seems to toggle it on and off for me. Not sure that this will work for everybody.

 

0

Please sign in to leave a comment.