Since webstorm 2019 2, vim-plugin has become unstable

What steps will reproduce the problem?

  • Try text search with text "/" with vim-plugin on

  • I can not type well when I try to type full-width characters

  • Return to normal mode with ESC key

  • "/" Does not appear even if you try to search text by "/" again

  • Rollback 2019 1

  • It works well.

Add
I tried according to this https://support.samuraism.com/hc/ja/articles/360033223134.

  • Set JBR8 and upgrade to 2019.2 again.
  • Not work.

 

6 comments
Comment actions Permalink

vim was acting very strange for me as well.

Looking at the fix for https://youtrack.jetbrains.com/issue/JBR-1693 the second workaround, changing the boot jdk, to the provided build fixed the issue for me.

1
Comment actions Permalink

thanks a lot.

It may not be recurring in the respondent's environment because it may be caused by complicated things such as the key setting of the pc.

I will report again if necessary if I can make progress and identify problems through trial and error in my environment.

 

1
Comment actions Permalink

Does it only happen with IdeaVim enabled? There are some issues entering Japanese in 2019.2 (https://youtrack.jetbrains.com/issue/JBR-1693, https://youtrack.jetbrains.com/issue/JBR-572)

0
Comment actions Permalink

I've found Vim mode also acting weird. In my case I have 3 split windows. One of the windows will enter a state where Vim seems completely disabled. Actually all editing. Presumably I'm in Normal mode, since the cursor is solid. Hitting Esc or any keystroke that would invoke Insert mode does nothing. All keystrokes seemed locked out. So although I see the solid cursor, any navigation keystrokes including arrow keys do not work. So effectively, the window is some what useless.

I say somewhat because interestingly if the window contains several tabs of files and I change tabs to another file, that one can edit. However if I return back to the offending tab, it still is "locked out".

0
Comment actions Permalink

must be https://youtrack.jetbrains.com/issue/VIM-1752, the fix is available in the IdeaVim EAP build 0.53.1

0
Comment actions Permalink

Thanks for the information. It is difficult at this point to tell if this is the same issue. They cite, "line mode" which I presume is Visual Mode. In my case I'm completely locked out with the keyboard for that given tab. I very rarely mix mouse text selection when using Vim. In these cases, I was simply switching between Normal mode and Insert mode. 

So in my case, pressing ESC does not "exit" from Insert Mode. I also do not appear to be in Normal Mode. Typing any character from the keyboard does not appear to "register" any key press, including the arrow keys (note arrow keys are supposed to work in Insert Mode), pressing Normal mode keys like 'i' do not put me into Insert Mode. And the cursor is solid which would mean I am either in Normal Mode or possibly Visual Mode. My only way to "fix" it is to close the tab.

When it happens again, I'll try and see if it registers Command+Shift+] (or [) to switch tabs.

Sadly there are numerous keyboard bugs with Vim it seems. Another one I notice is even though I remapped "Type Hierarchy" (defaults to Ctrl-H) to Shift+Ctrl+H, using Ctrl+H, which in Edit mode is a backspace still randomly causes the Type Hierarchy view to open. I've also seem numerous cases of Vim chords triggering other Webstorm Windows to popup. I do not believe these are errant presses on my behalf as I am a good typer and in these cases, I won't be, say in the process of using the Shift key, for example.

0

Please sign in to leave a comment.