Permission Denied on SFTP Deployment

Just moved from PyCharm 2018.3 (I think) to 2019.2. Now, when I am attempting to configure code deployment via SFTP, I get the following error:

 

[8/5/2019 4:40 PM] Upload to ******@********.com:22 failed: could not resolve file "sftp://********.com/mu". (Permission denied)

 

Checking on the server, it is indeed true that my user account does not have permissions to the /mu file/directory. However, I am quite happily able to SFTP into that same server using FileZilla with the exact same settings. Is there some way I can configure PyCharm to not use that /mu directory?

1 comment
Comment actions Permalink

Please try deleting ~/.pycharm_helpers directory from the remote host, and if this not helping, delete/recreate your SSH interpreter.

0

Please sign in to leave a comment.