I can't find Preferences menu on 2019.2 (IU-192.5728.98)

Answered

Hello.

 

OS: Mac

 

When I upgraded to 2019.2, Preferences menu was gone. Shortcut(Command + ,) also is not working.

 

How do I do?

 

Thank you

10 comments
Comment actions Permalink

Can you show the "IntelliJ IDEA" menu? 

https://i.imgur.com/cUsdVYJ.png

0
Comment actions Permalink

Sure~

 

 

 

0
Comment actions Permalink

You can workaround that by opening Preferences using Cmd+Shift+A (Find actions). 

And to fix the issue, try to run IntelliJ IDEA under JetBrains Runtime 8: 

https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

1
Comment actions Permalink

It's not showing any commands on Actions dialog.

 

And I closed IntelliJ IDEA and opened. But loading progress is not over.

 

I uninstalled all files. And Reinstall IntelliJ IDEA 2019.2. So it works well.

 

I think that there was problems about (open)jdk version.

 

Thank you

0
Comment actions Permalink

This happened to me today.  I had built another project that required JDK 11 and chose JDK 11 using the Choose Runtime plugin, then closed that project.  I opened up a JDK 8 project and it showed a popup asking me to use the built-in JDK, I clicked ok on that, then the Preferences menu disappeared and command + , only brought up the Maven side panel.  Command , did nothing.

Then I switched it back to Java 8 as recommended using Choose Runtime plugin and preferences menu came back.

Then, all the configurations showed a red x and opening Edit Configurations showed that there was no JDK selected, even though the pom.xml is set up for 1.8

I went to Project structure and chose Project SDK as 1.8, however, even though everything is built, nothing can be debugged.  Debug button is grayed out.

restarting intelliJ after that - it seems ok now maybe

1
Comment actions Permalink

It's not recommended to change JetBrains Runtime used to run IntelliJ IDEA, switch back to the default per https://intellij-support.jetbrains.com/hc/articles/206544879 .

JDK you are using for the project is not related to the runtime used to run the IDE itself.

0
Comment actions Permalink

JJones this was the exact scenario for me.  Using the JetBrains Runtime plugin messed up the short cuts: Cmd+Shift+A and Cmd + ,

I couldn't get to any preferences.  Well I still can't, but I'm going to try cycling through using the plugin again to see if it magically comes back.

0
Comment actions Permalink

If anybody finds that same issue: Still happens on IntelliJ 2021.1. There I don't have preferences for every JetBrains JDK after 11.0.10+9-b1379.1. I think the newer JDKs did work at some point but stopped late in the IntelliJ 2020.3.x lifecycle.

I set it back to the default - which is 11.0.10+9-b1341.35 - and it works again.

0
Comment actions Permalink

Please always use the bundled JetBrains Runtime unless instructed otherwise by JetBrains for the diagnostics purposes.

0
Comment actions Permalink

Serge Baranov Understood. Unfortunately, the "Choose Runtime" plugin page doesn't tell me that. It should!

0

Please sign in to leave a comment.