Break points and remote interpreter

While using a remote interpreter, break points (on local files) are ignored.
How am I supposed to debug remotely?



Indeed, breakpoints are set in local files, but they should take an effect when you run the script using SSH interpreter, so there's an issue.

- Does debugger work when you run with local interpreter?

- Have you changed any settings in Run > View breakpoints...

- Is the issue script-specific? Does it reproduce if you debug a minimal hello world script with SSH interpreter?

Also please try deleting ~/.pycharm_helpers on remote host and try again.


I have same problem. I tried deleting ~/.pycharm_helpers.

I think that pycharm 2019.2 have bug.


I could not reproduce this bug, in my case debugging remote scripts work without an issue.

Would you mind submitting a bug report (, providing steps to reproduce, your code snippet, or any other information you might find relevant?


I've managed to make it work.

I've added a remote interpreter and I could run scripts successfully.
Nevertheless, debugging seemed buggy. One needs to specify "Path mappings" in the "Run/Debug Configurations", although it was already configured in the "Deployment" configuration window.

I'd recommend to be able to import existing mappings, if these have already been specified.

Also, it would be quite convenient flagging that such mapping is missing, rather than silently successfully executing the script remotely.


I have the same issue as well. The break points are totally ignored when I use a remote python interpreter. I tried deleting the pycharm_helpers folder and reconfigured the remote interpreter again but that doesn't seem to have solved the issue. Any other suggestions/solutions which any of you tried?


Please sign in to leave a comment.