Multiple projects in same repository. WebStorm does not support auto imports for second repo?

We have one git repo with two angular projects in folder projects.

They work fine, but for the second application in WebStorm, it can't find any modules (even `@angular/core`) and can parse dependency for the second app.

When I in folder projects renamed projects (switched the order) the WebStorm started work correctly with the dependencies of the first one (which was second before renaming) and broken with the second one (which was first...). It looks like it can work just with the first folder...

How can I fix it?

6 comments
Comment actions Permalink

We are not aware of such issues. Please can you share a sample project that can be used to recreate it?

0
Comment actions Permalink

I tried to reproduce the same issue in the test project. But I got failure - all works... https://github.com/Nataliya-uzva/test-mono-repo

In my team, 5 persons work in WebStorm and have the same issue. Can it be related to some cashe?

We had two separate git repos and after some time move them in one monorepo (we made some changes with files in the first project prepare it into monorepo and move the second project (it is not working now) to the first one). We move all files with saving git history.

0
Comment actions Permalink

I can't reproduce it as well...

>Can it be related to some cashe?

Unlikely... But you can try deleting the caches with File | Invalidate caches, Invalidate and Restart - does it make things any better?

0
Comment actions Permalink

It is really strange because for the test project it is working fine.

 

But for all team it is not... all aliases work for the first project and does not work for the second. The builds work fine. Those projects already in production from one repo.

0
Comment actions Permalink

I can only suggest comparing your setup in test and production projects to see what is different...

0

Please sign in to leave a comment.