SVG preview in Webstorm 2019.2 not working.

Hi there!

There is a strange bug in webstorm 2019.2. When i try to set pattern to *.svg for Scaleable Vector Graphics in the Editor > File Types preferences i get a pop-up dialog warning stating "This wildcard is reserved for 'Files supported via TextMate bundles' filetype and cannot be reassigned. How do i fix this so that i can preview the svg files?

Regards,

Magnus

9 comments
Comment actions Permalink

Doesn't happen to me.

Please check Settings | Editor | TextMate Bundles - do you have any bundles for svg there?

0
Comment actions Permalink

Nope, no bundles for svg are listed. I just installed the webstorm as a clean install, and have nothing added except my usual preferences. May it be that my preferences from earlier is messing up the file types setting in the lastest version of Webstorm?

0
Comment actions Permalink

Hmmm, after a few restarts of webstorm the error went away and the pattern *.svg now appears in the file types for scaleable vector graphics. So I guess we can mark this one as solved, allthough I have no idea what caused the issue... :-)

0
Comment actions Permalink

may be... Did you import any preferences/plugins from previous version? Please try removing Webstorm preferences, caches and plugins (see https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs for information about configuration, etc. folders location) to start with fresh setup - does the issue persist?

0
Comment actions Permalink

I have the same problem. After upgrading to 2019.2 I can no longer preview svg files :-(

I have no bundles for svg under Settings | Editor | TextMate Bundles

Is there a way to import the svg bundle back in?

 

1
Comment actions Permalink

@Nick, you don't need textmate bundles for this.

Make sure that *.svg pattern is assigned to Scalable Vector Graphics file type in Settings | Editor | File Types:

 

0
Comment actions Permalink

Just noticed this as well in 2019.2. My Scalable Vector Graphics patterns was empty in File Types.

I can manually add the svg file type in but I'm wondering what other configurations issues there are since I've always imported my WebStorm settings from previous versions.

I'd rather not re-customize all my settings. Is there a way I can export these, reset 2019.2 and re-import?

Thanks!

0
Comment actions Permalink

Perfect Elena!! I missed that update; thank you for letting me know!

0

Please sign in to leave a comment.