PHP version set for the project isignored

file/Settings/Languages & Framewoks/PHP:

 

composer.json:

 

I got the following error:

 

why is it saying that my PHP version is 5.6.40 considereing I have set it equals to 7.2.18 (see first screenshot) ??

 

Thank you in advance or your help

 

2 comments
Comment actions Permalink

What the error says is that the interpreter you are using to run Composer is 5.6.40, so that must be the case. If you are running Composer from within the IDE (Tools/ Composer menu) please review the Execution settings at Languages & Frameworks/ PHP/ Composer. If you are running it from command line, then you need to ensure that the intended PHP interpreter comes first in PATH, or either type the full path.

0
Comment actions Permalink

I thought the composer was run from within the IDE as I was doing a right-click on the composer file in the IDE.

I ended up changing the Path and it solved my issue.

Thank you

 

0

Please sign in to leave a comment.