EditorConfig doesn't work in WebStorm 2019.2

here is my .editorconfig file content

```

root = true

[*]
charset = utf-8
indent_style = space
indent_size = 2
end_of_line = lf
insert_final_newline = true
trim_trailing_whitespace = true

[*.md]
trim_trailing_whitespace = false

```

when I update WebStorm from 2019.1.4 to 2019.2

EditorConfig doesn't wort.

I use Ctrl+Alt+L to format my code,but indentation become 4!

check my settings

indent is 4.

but why it was not overridden by editorConfig?

And the warning in red mark is ?

==========

env: windows 10, webstorm 2019.2 build #WS-192.5728.87

==========

what should i do?

5 comments
Comment actions Permalink

What files do you work with? It works fine for me when editing .js files

0
Comment actions Permalink

Same issue for me when I coding .vue files. I tried .js and it worked fine.

But .vue files used to work with .editorconfig well before too.

This happens after I updated to 2019.2.  Is this Vue plugin's problem?

0
Comment actions Permalink

@Elena Pogorelova

Forgot to mention minor version, but I'm actually using 2019.2.1 :/

I just checked again and it still happens for .vue file.

 

Oh yea sorry, I'm not using Webstorm. I meant IntelliJ Ultimate 2019.2.1

0

Please sign in to leave a comment.