Problems with IntelliJ starting up

Answered

I recently had to do a hard reset on my machine, whilst IntellIj was working.  After rebooting I am getting the following error message:

 

Anybody had this and found a way to resolved it ?

4 comments
Comment actions Permalink

Please see https://intellij-support.jetbrains.com/hc/en-us/articles/360007568559 .

Also try "netsh winsock reset" in the command line and reboot.

0
Comment actions Permalink

Thanks, the issue seemed to resolved itself after a few reboots and being off the network.. I didn't get a chance to try the netsh winsock reset.

1
Comment actions Permalink

Can't believe this still isn't fixed yet. If you don't feel like rebooting (netsh winsock reset) every time a JetBrains IDE doesn't feel like starting, you can generally fix it by typing "ncpa.cpl" into your start menu search, or the "Run..." dialog box, then right-click each network adapter there one at a time and click "Disable" followed by right-clicking again and clicking "Enable" (obviously don't do this if you're remoting into the machine).

 

Or here's a nice Powershell one-liner to do it for you to run at an elevated (admin) Powershell prompt:

Get-NetAdapter | Disable-NetAdapter -Confirm:$false -PassThru:$true | Enable-NetAdapter

Why would I necro a nearly year old thread to say this? Because it's now a top result on Google when searching for that magical netsh command that makes JetBrains actually start.

0
Comment actions Permalink

Phillip Stromberg

It's Windows issue reserving too much common ports, see this ticket for more details and the proper workaround: https://youtrack.jetbrains.com/issue/IDEA-238995 .

If you can suggest a better solution for cross platform folder locking and IPC that will work everywhere, not trigger antivirus/firewall and handle huge ranges of blocked ports, patch is welcome, this subsystem is open source: https://github.com/JetBrains/intellij-community.

0

Please sign in to leave a comment.