Import suggestions are not working properly.

Answered

While using latest version of IDEA on a AS3 project, I'm running into issues when trying to import classes to my code, example below:

https://i.gyazo.com/8f714c944b35d2d311eaa55efa34f817.png

 

Also happens for example with the class Event from Starling, it just can't find it:

 

https://i.gyazo.com/99db84b153a27c4fa4286035109eaaa3.png

 

This never happened before for what I remember.

 

Thanks.

1
9 comments

Have you tried invalidate caches and restart?  Sometimes when I upgrade to the new Android Studio or IntelliJ IDEA, the caches just don't work.

0

Yes I tried that before posting. I remember that happening before.

0

Hello, please clarify, are the classes marked as resolved when you import them explicitly, so only the completion and import suggestion don't work or the classes are marked as unresolved when you explicitly import them?

Please check the settings: Preferences | Editor | General | Auto Import, probably some libraries are added to "exclude from import and completion" list?

Can you also please create a little sample project where the issue is reproduced for you? Thank you.

0

It works when I importing them manually, but the autocomplete doesn't offer the option of importing them like I used to.

 

This is happening in a fairly new project, so I doubt any settings are being changed.

 

Will try at home, at work right now.

0

I checked those options, I have nothing added there.

I can send you a sample project if you need.

 

0

Pablo, if possible can you please create an issue at YouTrack (https://youtrack.jetbrains.com/issues) attaching the sample project to it. Thank you.

0

I had the same problem with mac, and 2022 (Build #PY-221.5080.212, built on April 12, 2022) pycharm. The "inspections" was pretty much broken and it wouldn't highlight red or auto suggest to include a new package.

Uninstalling and reinstalling did not work. 

I noticed on welcome page to PyCharm, it still had the a cache of projects which I had removed. So I did a "Restore Default Settings" and it was finally fixed.

0

The only thing that worked for me is "deleting the .idea folder" in my project.

2

thank you Apoorvaeternity.

After that I could even restore the .idea folder that used to be “broken” and it is working again. For a moment I was in anxienty of loosing my shelves, tasks, changelists etc 😰 

Still experiencing https://youtrack.jetbrains.com/issue/DS-3139/Stuck-on-Waiting-for-process-detach (which happens as harbinger to the topic of this post) although I can see in the console that the process already has been shut down sucessfully.

0

Please sign in to leave a comment.