PyCharm SSH interpreter stays “Connecting to pi@10…” forever

I currently build raspian-buster on a brand new sd card and I'm trying to set the remote interpreter on pycharm via SSH.

I'm able to start SSH sessions using Putty or even using the SSH session that is available at pycharm in the "tools" menu.

I've done this process before and the thing is that when I put into the popup the info requested it turns to another window and just stays "Connecting" forever.

-I've checked my plugins and they are okay.

1 comment
Comment actions Permalink

Could you please upload logs for a deeper investigation? 

Please extend the logging level by adding

#com.intellij.ssh
#com.jetbrains.plugins.webDeployment

to**Help | Debug Log Settings…** , then please reproduce the issue.

Collect logs https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files

Here is the FTP https://uploads.services.jetbrains.com/  , once the logs uploaded please let me know the folder name. 

 

Thank you! 

 

 

0

Please sign in to leave a comment.