How to prevent pycharm from doing the tasks on startup (takes > 5 minutes to startup)

Since pycharm takes up a lot of memory and is very slow, I need to close pycharm several times during the day. However, it start up is very slow as I think it is indexing and also doing a lot more other tasks. After it started. It takes up to 5 minutes for me to be able to even start typing something and see it reflected on the screen.
So I was wondering if there is any way to list all the tasks that pycharm does when it starts up. And also, how to disable some of the tasks.
In other words, I am trying to
thank you for any inputss

4 comments
Comment actions Permalink

I think you should reach out to support, there are ways to optimize the start up or perhaps there isn't enough memory allocated, or your project is huge, or you might be indexing files you should exclude from indexing (like a massive CSV you are working on, for example). Just googling slow start up with pycharm will also return a host of possiblities.

They have some information here you might want to collect first before reaching out

https://intellij-support.jetbrains.com/hc/en-us/articles/207241235

1
Comment actions Permalink

Hello John, 

As it was previously mentioned, please collect logs described in "Profiling slow startup" https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems 

Upload it to the FTP https://uploads.services.jetbrains.com/ and let me know the folder name for a further investigation. 

1
Comment actions Permalink

Thank you. I just finished uploading the file. I thought I would be allowed to rename the file *after* uploading but it was not possible. So the file is named generically as pycharm64.exe-2019-09-07-shutdown.snapshot . I hope it does not conflict with any other filename. The current time is 00:02:00 EST.

The max time is taken when I start pycharm the first time every morning. Subsequent starting up are faster. For example, loading components and opening project takes about 2 minutes the first time.But next time it loaded within a minute (the second time is what I have uploaded the profiling snapshot from). The time taken for indexing files is about 5 minutes and then querying and generating skeletons is another 5 minutes. The indexing and skeletons is what takes a lot of time. 

 

The project is loaded within 3 minutes but after that I cannot do any work (because it takes more than a minute to get response from a keystroke) until the indexing and skeleton process is completed

So I am hoping for some way to stop indexing and skeleton at least for the second time. It seems that indexing happens every morning (possibly from scratch) even though none of the files have been altered or the timestamp changed on them. Same with skeletons. e.g. I just executed 1 process yesterday and yet indexing happens for 5 minutes.

This is on 2019.2 release(could not make performance plugin  work on 2018.2). The project that I have been using was created on 2018.2

0
Comment actions Permalink

Thank you for the detailed description, I should have asked to upload logs in my first reply.

Please upload your logs folder zipped from Help | Compress Logs and Show in. 

Could you tell me what interpreter is configured? (anaconda, ssh, etc..)

If you have any Antivirus software or  Windows Defender enabled, please try to disable it.

To improve indexing performance, please  try to "Invalidate caches" (https://www.jetbrains.com/help/pycharm/cleaning-system-cache.html#2b0a8644)

Another thing I would ask you to do is create a new project with a new interpreter and see if there are any changes. 

0

Please sign in to leave a comment.