GoLand Shortcuts

Hi,

 

I'm working with PyCharm several years and now I start working with GoLand.

There are some keyboard-shortcuts that doesn't really work the same and I don't understand why, for example:

Cmd+Shift+LeftArrow when the user is focus on the Project navigation pane doesn't resize the pane, instead it "selecting" all the file to the root. From little bit investigating I saw that there is shortcut called "Move caret to Line Start with Selection" that holds this one and override others.

I tried to switch the shortcuts and it's work but now I can't select text to the start of the line (with Cmd+Shift+LeftArrow). It's sucks. In PyCharm I had both.

Another shortcut is moving between Console and Debugger at the Debugging pane. The shortcut Cmd+Shift+[ or Cmd+Shift+] doesn't work.

 

Help anyone?

8 comments
Comment actions Permalink

Hi Hanan.

Thank you for the feedback.

Cmd+Shift+LeftArrow when the user is focus on the Project navigation pane doesn't resize the pane

It does for me. What's the exact version of GoLand you use? What keymap you use? Could you attach logs, please (Help | Compress logs and show in <file browser>)?

Another shortcut is moving between Console and Debugger at the Debugging pane

It's known regression, please vote for the issue here: https://youtrack.jetbrains.com/issue/IDEA-220837

0
Comment actions Permalink

Hi,

Here is a GIF that describes my issue with the Cmd+Shift+LeftArrow shortcut:

Here's picture of the relevant keymap

 

Thank you very much.

0
Comment actions Permalink

Hi Hanan,

I'm sorry, but the images are not helpful for recreating the problem.

What's the exact version of GoLand you use? What keymap do you use? Could you attach logs, please (Help | Compress logs and show in <file browser>)? Could you share the keymap (File | Export settings)?

0
Comment actions Permalink

Hi, 

Thanks for the fast reply

My setup

  • Mac Mojave (10.14.5)
  • GoLand version: GoLand 2019.2.1 Build #GO-192.6262.60, built on August 21, 2019

I can't attach here files that aren't images.

If there is anything else I can provide to fix this issue just tell me.

Thank you very much!

0
Comment actions Permalink

Hi Hanan,

Both links respond with 404 :(

Feel free to mail files directory to my email: zolotov@jetbrains.com.

0
Comment actions Permalink

Hi!

That's a known regression in Idea, see https://youtrack.jetbrains.com/issue/IDEA-218926 

We couldn't reproduce it because it is already fixed in our next version, 2019.2.2

That should be ok after our next release

0
Comment actions Permalink

Thanks!

When should be the next release?

 

0
Comment actions Permalink

Exact dates could be changed yet, but we plan it in a couple of days :)

0

Please sign in to leave a comment.