Deployment excluded paths - default selected path

In Build, Execution, Deployment settings, when I go to exclude a local path the "Select path" dialogue always starts in the same place - a subfolder of a site I haven't worked on in months. It doesn't seem to matter where the project I'm working on is located, it always starts in this totally irrelevant location.

Is there a place I can set where it starts? Or clear whatever preference has caused this?

4 comments
Comment actions Permalink

Tried to reproduce on PhpStorm 2019.2.1 without any luck -- the dialog always starts in the current project directory.

A somewhat generic question but nevertheless, what version of PhpStorm do you have? Also, could you please confirm that it happens only for file dialog called from Deployment settings or other windows are affected too?

0
Comment actions Permalink

Another idea -- please check if you have something added to "Project opening, Default directory:" in "File | Settings | Appearance & Behavior | System Settings"

0
Comment actions Permalink

So sorry I forgot to reply to this Vasiliy. Project opening, Default directory was indeed where the problem was. Thank you!!!

0
Comment actions Permalink

No worries at all, glad to know that things are working fine now. Have a fantastic day!

0

Please sign in to leave a comment.