Setting up pipenv in python project and virtualenv

I am trying to setup python and pip in a new project using virtualenv on mac OS X.

Version details: 

IntelliJ IDEA 2019.2.2 (Community Edition)
Build #IC-192.6603.28, built on September 6, 2019
Runtime version: 11.0.3+12-b304.56 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.6
GC: ParNew, ConcurrentMarkSweep
Memory: 990M
Cores: 4
Registry:
Non-Bundled Plugins: BashSupport, PythonCore

Mac OS version: Mojave, 1014.6

> python --version

Python 2.7.10

> pip --version

Running: python -m pip --version

pip 19.2.3 from /Library/Python/2.7/site-packages/pip (python 2.7)

 

The issue is when I try to set up pip in under the project structure I am seeing an error.
     "no such option: --python"

If I run the command that IntelliJ says it is running on the cli I see the same error.

>pip --python /usr/bin/python2.7 install --dev

Usage:   

  pip <command> [options]

no such option: --python

Looking at the pip usage there appears to be no --python option.

1 comment
Comment actions Permalink

Hi, unfortunately it's not clear what exactly you're doing. Would you mind providing steps to reproduce the issue?

0

Please sign in to leave a comment.