Keyboard stops working after using modal dialog.

Answered

I'm not sure whether this is related only to IntelliJ but so far I haven't experience following issue with any other application.
When I use modal dialog, like one for auto generated code. After the code is generated I cannot use keyboard, it doesn't respond inside editor. The mouse however still works. 

The workaround is to click somewhere else to lose focus, and the click again on IntelliJ after the keyboard starts working again. It happens every time under described condition. 

The system it's running on is Arch Linux with:
- kernel 5.3.1-arch-1-1-ARCH
- Gnome 3.34.0

Let me know if I can provide some additional details in order to diagnose the root cause.

12 comments
Comment actions Permalink

Could you please provide information from "Help | About" (we need to know IDE and boot JDK build numbers)?

0
Comment actions Permalink

Yeah sure.

IntelliJ IDEA 2019.3 EAP (Ultimate Edition)
Build #IU-193.3519.25, built on September 18, 2019
IntelliJ IDEA EAP User
Expiration date: October 18, 2019
Runtime version: 11.0.4+10-b480.2 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.3.1-arch1-1-ARCH
GC: ParNew, ConcurrentMarkSweep
Memory: 1981M
Cores: 8
Registry: ide.tree.ui.experimental=false, ide.balloon.shadow.size=0
Non-Bundled Plugins: MavenRunHelper, actiBPM, com.alexanderpa.flyway.migration.creator, com.chrisrm.idea.MaterialThemeUI, com.jetbrains.ChooseRuntime, some.awesome

0
Comment actions Permalink

Could you please check if the problem persists after modifying custom properties:
1. Press `Help | Edit Custom Properties...` (if a dialog appears, press "Create")
2. "idea.properties" file will open. Add `suppress.focus.stealing.linux=true` to a new line
3. Restart IDE

0
Comment actions Permalink

Sadly it didn't help. The problem persists.

0
Comment actions Permalink

Thank you.

I filed a new issue: https://youtrack.jetbrains.com/issue/IDEA-223597

Please, vote and follow for updates. If you are not familiar with YouTrack, see https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications

Could you please also tell, do you use Wayland or Xorg protocol?

0
Comment actions Permalink

I use Wayland by default. Also just did the quick check with Xorg and the issue is present there as well. 
Will add additional comments to the ticket.

Thanks for your support.

0
Comment actions Permalink

I did have this issue, but updating to Gnome 3.34.1 has solved it for me.

0
Comment actions Permalink

Hi guys, as I'm looking around, this issue perfectly describes my current problems. I'm running current Kubuntu 19.10 with KDE Plasma 5.16.5. It only happens in about 50% cases, suppress.focus.stealing.linux=true doesn't make any difference. Turning compositor on/off also makes no difference. Mainly noticing on Ctrl+N (Navigate to class) where no input is accepted until loosing focus and dissapearing. 

I also noticed that resizing the modal using mouse pointer fixes this stale state. 

Here my About:

IntelliJ IDEA 2019.3.4 (Ultimate Edition)
Build #IU-193.6911.18, built on March 17, 2020
Runtime version: 11.0.6+8-b520.43 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.3.0-45-generic
GC: ParNew, ConcurrentMarkSweep
Memory: 1950M
Cores: 4
Registry:
Non-Bundled Plugins: Batch Scripts Support, GrepConsole, Lombook Plugin, com.intellij.apacheConfig, com.intellij.plugins.html.instantEditing, com.jetbrains.php, com.jantvrdik.intellij.latte, com.jetbrains.php.blade, com.jetbrains.plugins.ini4idea, de.espend.idea.laravel, mobi.hsz.idea.gitignore, org.jetbrains.kotlin, ru.adelf.idea.dotenv

Cheers, Tom

0
Comment actions Permalink

Oh and one more thing worth mentioning. My IDEA is installed from Snap.

snap list 

Name Version Rev Tracking Publisher Notes
intellij-idea-ultimate 2019.3.4 212 latest/stable jetbrains✓ classic

0
Avatar
Arseniy Nisnevich
Comment actions Permalink

Hi Tomas,

Could you try the following:
1. Press `Help | Edit Custom Properties...` (if a dialog appears, press "Create")
2. "idea.properties" file will open. Add to a new line:

suppress.focus.stealing.active.window.checks=true

suppress.focus.stealing.disable.auto.request.focus=true

3. Restart IDE

0
Comment actions Permalink

Hey Arseniy,

that seems to work! Thanks heaps!

My IDEA updated in the meantime too (2020). Not sure what did it but seems to be working just fine now. Running like this 

IntelliJ IDEA 2020.1 (Ultimate Edition)
Build #IU-201.6668.113, built on April 7, 2020
Runtime version: 11.0.6+8-b765.25 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.3.0-46-generic
GC: ParNew, ConcurrentMarkSweep
Memory: 1950M
Cores: 4
Non-Bundled Plugins: Batch Scripts Support, com.intellij.apacheConfig, GrepConsole, com.jetbrains.plugins.ini4idea, com.intellij.plugins.html.instantEditing, com.jetbrains.php, ru.adelf.idea.dotenv, com.jantvrdik.intellij.latte, com.jetbrains.php.blade, de.espend.idea.laravel
Current Desktop: KDE

With all custom flags set to true

suppress.focus.stealing.linux=true
suppress.focus.stealing.active.window.checks=true
suppress.focus.stealing.disable.auto.request.focus=true
0
Avatar
Arseniy Nisnevich
Comment actions Permalink

Tomas,

Thanks for the update. If you face the problem again, let me know.

Here's a related issue: https://youtrack.jetbrains.com/issue/JBR-1822

0

Please sign in to leave a comment.