WebStorm (fresh install) doesn't recognize HTML tags

I installed the latest version of WebStorm, selected my plugins, and started a new project.  I created an index.html file with the following content:

 

<!doctype html>

<html lang="en">
<head>

</head>
<body>

</body>
</html>

 

And I have a bunch of warnings: 

  • Unknown html tag html
  • Unknown html tag head
  • Unknown html tag body

I'm pretty sure that's not normal behaviour, right?  WebStorm should recognize html files and all common html tags.  What could have gotten screwed up?  What can I check?

8 comments
Comment actions Permalink

check the custom plugins you have installed. For example, the React-Templates plugin is known for breaking the HTML5 schema causing similar issues

10
Comment actions Permalink

You nailed it.  I disabled only the React-Templates plugin and now WebStorm is happy with HTML files again. 

7
Comment actions Permalink

Disabling the plugin worked for me also.  Thanks!

0
Comment actions Permalink

Same. Disabling React-Templates fixed it.

0
Comment actions Permalink

I had this problem about 1 month . For solve look at this picture.Go to Setting/plugins.click at icon at top right(like below).Then select "Disable All Downloaded Plugins".Then enable one per one for find broken plugin.

0
Comment actions Permalink

In my case it was NativeScript plugin. Plugin version 0.21.0

3
Comment actions Permalink

Thank you very much Nikita Dyomin, I was trying to figure this out for weeks !

0
Comment actions Permalink

I confirm the problem with NativeScript plugin 0.21.0 for PhpStorm 2021.3

0

Please sign in to leave a comment.