New Project window is blank and can't be closed


Using 2019.2.3 when I click new window I get a blank window which I can't close and I am forced to kill PyCharm from the task manager. I've tried reinstalling and clearing out the registry with no luck. Anyone else seen this? Is there a way to fix it?


Some more details on enviroment

openjdk version "12.0.1" 2019-04-16
OpenJDK Runtime Environment (build 12.0.1+12)
OpenJDK 64-Bit Server VM (build 12.0.1+12, mixed mode, sharing)


Had high hopes that the JDK was the problem and yet PyCharm appears to be using it's own JBR and still exhibits the problem after choosing install which selects and restarts the IDE with the selected runtime.


I experience the same problem. Is there any solution?


Experience same issue in IntelliJ IDEA Ultimate since latest update (2019.3 Build UI-193.5233.102).

It doesn't happen every time, just from time to time, when I close project the main window stays opened. Clicking on 'x' (close) button doesn't do anything

But due to "multiple instances management in single process"  I cannot just do File->Exit because it will close all my open projects. So I have to keep working with this blank window until I finish work on all projects (which is very rare - I switch all the time between them) or got frustrated of this empty window




the issue has been reported here , please feel free to vote for it and follow for updates. 


Also seeing this problem with PyCharm 2019.3.1 (#PY-193.5662.61) -- pretty annoying. I don't think the issue reported above is the same, as for me this happens when I close a project. Also since the indicated issue is marked as "third party" there's doesn't seem to be a way to vote for it.

Would love workaround or fix


Lou King I have the exact same problem as you described, with PyCharm 2019.3.2. It's very annoying when you are used to often open/close multiple projects.

Edit : It seems to be fixed in the EAP


This has just started happening to me in Intellij Idea 2019.3.2. Same as @Pavelpe  


Just updated to newest Intellij Version 2019.3.3:


Funny thing, now if this happens (main window is not closed), then the window itself is "hidden" (I don't see it any where) BUT the service itself is still alive and I can see it in running processes (Ubuntu 16.04 LTS) and Intellij icon in Launcher.

So I have to kill the process manually. 


Has anyone from the  JetBrains team acknowledged the issue? It's extremely annoying and interferes with my work. Started happening after the last couple of updates.


It's marked as "Third Party Issue" at

So it's not possible to vote for it, but I can't find which third party mentioned anywhere.




Should be fixed in 2020.1  , please this as well 


This has been happening since last year, still happening even though I run every update prompted:

I close a project by clicking the red button at the top left (normal Mac OS window close button), and everything closes inside of it, but the window won't go away, and the red button at the top left doesn't do anything but blink.

Close Project is grayed out... opening up the same project in a new or same window just opens it in a new window but still nothing closes the blank window except for quitting the editor.


I keep seeing updates to this where people open a ticket, mark it as a duplicate of a 'solved' issue and close it.... but I've been seeing it for months in Webstorm.  I tend to have 5-6 projects open at once, so as of right now I have 5 dead windows from closed projects that I can't get rid of (unless I close the whole of WebStorm down, which involves also shutting down/restarting some debuggers and node apps running inside some of the instances).

There's also an annoying issue where you can sometimes (on a mac) you can't type in windows.  You have to actually click a totally different application altogether and then come back in order to be able to select a window that you want to type in.

Little things like this are reasons why I'm starting to shop around to see what other things are out there which might be worth a go of... I've found over the last year the Mac Webstorm client to be more and more power hungry / ram hungry / buggy.


I'm still getting this in the latest PhpStorm on OSX.

Also, copying and pasting files from Finder to PhpStorm often switches the foreground window with that of other opened projects in the background.


Same Problem here, Windows are not closing and can´t be closed without closing the whole IDE. This bug is around for years, fixed a dozen times but still occurs regularly since a couple of months (and several updates later). Clearing Cache->no effect.

REALLY ANNOYING (among other things which really make me look for some other IDE, not only due to your latest pricing updates).


Is it reproducible in the latest version 2020.1?
If so, please report it to providing your idea.log from Help | Show Log in...


I cannot install the latest Update... Do you know what I mean? :-)


What happens if you proceed?
Alternatively, you can install it in parallel with the existing PyCharm installation.


Same Problem since years here! Now on new Mac Mini with Catalina and latest PHPStorm. When i close a project the IDE Window Frame remains open. Have to restart phpstorm completely. Absolutely annoying!!


I am having the same problem. Very annoying since I am working with 5 projects. 


This still happens to me in PHPStorm. It happens randomly. I can't figure out anything consistent that is causing it, nor any solution. The only thing that gets rid of the window is closing PHPStorm and opening it again. It appears to be a nasty bug.


Please sign in to leave a comment.