EduTools Installed but not working. Chooser window (Learning or Teaching) didn't show up.

Hi.

I posted this issue as a guest with the send request form, but it didn't get sent to public and I think it was only sent to the JB support and not the community, and I want it to be public so everyone can see, answer, and also future people with the same problem can benefit from it... But if the request I already sent isn't showing up because it needs to be approved then I'm sorry for duplicating, please remove one of them.

Anyway, here's the problem I'm having:

I installed the EduTools plugin in PyCharm. But it's as if I didn't install it at all! The only effect it had is a 'Learn more about Edu Tools' in the Help menu!
The chooser screen/window did NOT show up at all!
I searched and looked around a lot to try to fix this myself, like perhaps by finding some configuration files or something, but I failed to do so.
Obviously I tried disabling and enabling, and also removing and re-installing. Didn't work.
I run PyCharm on Linux. Specifically a Debian-based distro.
Didn't find anything in particular in the logs, but if it helps I'm happy to post my logs. (I really don't think you'll find anything in the logs!)
Thanks.

1 comment
Comment actions Permalink
Official comment

Hello,

Thank you for your feedback.

The role selection window is available only in IntelliJ IDEA Edu and PyCharm Edu.

If you have PyCharm Community or PyCharm Professional, you can enable the course creation functionality in Help | Enable Course Creator Features.

Once the plugin installed, you can browse the courses, join projects and courses on Hyperskill and Stepik, complete missions on CheckiO, and so on.

To browse the courses, go to Learn | Browse Courses from the Welcome Screen.

Please let us know if it helps.

Please sign in to leave a comment.