Debugging with xdebug doesn't work

Answered

Hello. I have the following problem. After I had configured xdebug and PHPStorm ( version 2018.1 ) debugging still doesn't work. I already searched for solution of my problem on this forum and in google, but still left unanswered. My problem is when I click on listening for debug connection and the run debug, in appearing debug window all buttons( Step into, Step out etc) are disabled, and debugging itself doesn't work(no variables or constant values are present). Below is what it looks like. 

Earlier there was also the followng message in the bottom of window - 

"Debug session was finished without being paused.

It may be caused by path mappings misconfiguration or not synchronized local and remote projects. To figure out the problem check path mappings configuration for 'laravel' server at PHP|Servers or enable Break at first line in PHP scripts option (from Run menu). Do not show again"

I've correctly resolved path mapping but it was not enough.

Please help me. I am in despair.

2 comments
Comment actions Permalink

You are using an Xdebug version that PhpStorm 2018.1 doesn't support, they have changed the protocol in (I believe) Xdebug 2.7. Please either downgrade Xdebug or upgrade PhpStorm.
https://youtrack.jetbrains.com/issue/WI-43622

1
Comment actions Permalink

Eugene, thank you very much. With your help I solved my issue.

0

Please sign in to leave a comment.