[CLION] No WSL in toolchain settings

Answered

I'm using CLion 2019.2.4, and when setting up WSL2 for Windows 10 (Build 18999.1) there is no option for "WSL".

 

Here is my screenshot:

compared to the wsl guide:

Solutions tried but not working:

  • If you specified the path to ubuntu.exe correctly, but CLion still cannot find the executable, the reason might be the WSL issue fixed in Windows 10 version 1803. You need to either update your system to the version 1803 or later, or enable the wsl.close.process.input key in the Registry (go to Help | Find Action, type Registry, and search by the key name).
  • If you get the Credentials are not valid for this WSL distribution error when creating a toolchain, check the value of HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Lxss{ubuntu_id }\BasePath in the Windows Registry Editor (to access it, launch regedit from the Start menu). In case the value contains non-ASCII characters, use the workaround described in this issue.
  • Due to the IntelliJ platform issue, there are problems with using WSL file-system which is case-sensitive and Windows file system which is not. As a workaround, you can do the following:

    • Go to Help | Edit Custom properties... menu option and specify

      idea.case.sensitive.fs=true

      Invalidate caches and restart the IDE using File | Invalidate Caches and Restart menu option.

Also, registry entry `Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Lxss\` doesn't contain any non-ASCII code.

Finally, I am 100% sure ssh in WSL is configured correctly

3 comments
Comment actions Permalink

Hello!

>I'm using CLion 2019.2.4, and when setting up WSL2 for Windows 10 (Build 18999.1) there is no option for "WSL".

It's really strange. Please go to File | Settings | Plugins and check whether the Remote Hosts Access and Remote Hosts Data Access plugins are installed and enabled.

0
Comment actions Permalink

Hi Anna, after enabling remote hosts access, it worked!!

Thank you very much. But it's strange that I didn't see this plugin requirement anywhere in the documentation

0
Comment actions Permalink

Actually, they are bundled. But I created a task about adding a note to the web help: https://youtrack.jetbrains.com/issue/CPP-17681.

0

Please sign in to leave a comment.