MacOS 10.15 Catalina PHPStorm XDebug issue

php 5.6 xdebug 2.5.5

log:

Log opened at 2019-10-14 14:05:24

I: Checking remote connect back address.

I: Checking header 'HTTP_X_FORWARDED_FOR'.

I: Checking header 'REMOTE_ADDR'.

I: Remote address found, connecting to 127.0.0.1:9000.

I: Connected to client. :-)

-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///Users/ptrepachko/Projects/roguefitness/roguefitness.com/httpdocs/info.php" language="PHP" xdebug:language_version="5.6.40" protocol_version="1.0" appid="94280" idekey="PHPSTORM"><engine version="2.5.5"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2017 by Derick Rethans]]></copyright></init>

 

-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" status="stopping" reason="ok"></response>

 

Log closed at 2019-10-14 14:05:24

 

PHPStorm does not stop at breakpoint

6 comments
Comment actions Permalink

Started happening after update to MacOS 10.15

0
Comment actions Permalink

This is not PhpStorm that Xdebug is connecting to. Please check this SO answer: https://stackoverflow.com/a/49408235/8018879

1
Comment actions Permalink

You saved my day. On friday i didn't managed to get it working. Tried different ways. On High Sierra it worked, but on Catalina it couldn't.

Thanks a lot ! 

0
Comment actions Permalink

Unfortunately this did not fix my problem.  As far as I can see I have a very similar problem.  The log indicates that xdebug connects, yet PhpStorm does not break.  I am using an older version of phpStorm (2016,3)  Same issue.  It worked fine before Catelena stopped after upgrade.  it is also using the newer OSX supplied xdebug,so library.

Log:

[72623] Log opened at 2019-10-23 20:17:50

[72623] I: Connecting to configured address/port: localhost:9001.

[72623] W: Creating socket for 'localhost:9001', poll success, but error: Operation now in progress (19).

[72623] I: Connected to client. :-)

[72623] -> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" fileuri="file:///Library/WebServer/drupal-7.67/index.php" language="PHP" xdebug:language_version="7.3.8" protocol_version="1.0" appid="72623"><engine version="2.7.0"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[https://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2019 by Derick Rethans]]></copyright></init>

[72623]

[72623] <- feature_set -i 1 -n show_hidden -v 1

[72623] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="1" feature="show_hidden" success="1"></response>

[72623] ...  more

0
Comment actions Permalink

Tom, you are having a different issue, in your case, PhpStorm is actually communicating with Xdebug.
What's wrong is that you are using an older PhpStorm version and Xdebug 2.7, they changed the protocol in this version so you either need to downgrade to Xdebug 2.6 or upgrade PhpStorm to a more recent version, the earliest version that has this fix is 2018.2.
https://youtrack.jetbrains.com/issue/WI-43622

2
Comment actions Permalink

Eugene,  Thank you so much for the quick response!  I was thinking it might be a version issue.

0

Please sign in to leave a comment.