Unable to sync configuration to/from git repository

Hello. I've been using IntelliJ for long time now but very recently I've switched to GoLand. I am using GoLand 2019.2. I remember in IntelliJ I could save IDE settings to Git repository (I have a GitLab repo already with IntelliJ settings) but I can't find the same options in GoLand. How do you activate it?

I've read documentation[1] and tried to follow but can't find "File/Setting repository" menu. It's just not there. I've made sure syncing to JetBrains account is disabled - I tried both: disabling sync and I have disabled the plugin at all to be sure. In both cases no option is there to set up syncing to my own repo. Any help would be appreciated. Thank you!

[1] https://www.jetbrains.com/help/go/sharing-your-ide-settings.html#settings-repository

Official comment

GoLand doesn't bundle Settings Repository plugin, you need to additionally install it. We'll update the documentation accordingly as now it's missing this step what can be confusing. I'm sorry for the inconvenience.

Indeed that worked. Thank you.


Hm, I thought it does but as I've tried to add my repository I've encountered some issues.

My repository is hosted on GitLab. I've tried to add `git` link and have been informed that "The authenticity of host 'gitlab.com' can't established" (including RSA fingerprint.) So then I've tried to use `https` link and user/password appeared but my credentials are not working. On second try there was no error message but, surprisingly, URL address text field became red and, after mouse hover, it said "Authentication not supported"

I am quite sure it works fine in IntelliJ because settings because it updates repository when I use it everyday other day. In IntelliJ I am using `git` link.

If that changes anything - I use GoLand on MacOS and IntelliJ on Win10.


>"The authenticity of host 'gitlab.com' can't established" (including RSA fingerprint.)

This is absolutely fine. This is the question that SSH asks when you access a host for the first time. Did you confirm? If yes what happened next?


Ah, how could I forget... This is new machine and the key was not in GitLab. So I've added my public key on GitLab web page, just few minutes ago. But it works fine and I can clone repository in shell.

Now, coming back to GoLand. It doesn't ask the question anymore, but silently fails. Red border again, says "Auth fail" on mouse hover. I've restarted GoLand with cache invalidated, restarted PC too, just in case.


Am I right that you're using git-link when getting Auth fail error? Is this URL in ~/.ssh/known_hosts?


Yes, you're right. Host is there, as below.

cat ~/.ssh/known_hosts | rg gitlab
gitlab.com, ecdsa-sha2-nistp256 AAAAE2VjZHNhLXNoYTItbmlzdHAyNTYAAAAIbmlzdHAyNTYAAABBBFSMqzJeV9rUzU4kWitGjeR4PWSa29SPqJ1fVkhtj3Hw9xjLVXVYrU9QlYWrOLXBpQ6KWjbjTDTdDkoohFzgbEY=


I see. We now need to analyze log files. As they may contain sensitive information, I'd appreciate it if you file a new issue here and attach there the resulting archive of Help | Compress Logs and Show in Finder. You can restrict visibility to jetbrains-team so no one else can see it.


I've created settings repository on GitHub for a test. Again, I can't use this repository, too. Both GitLab and GitHub are giving me the same response "Auth fail". Both can be cloned in shell using `git clone command`.
For a test I've done the same on Windows10 machine. I installed GoLand there and it works.
Here on MacOS it doesn't.

Win10 shell OK, Win10 GoLand OK, Mac shell OK, Mac GoLand "Auth fail."

Any clues or anything I could do to troubleshoot?


As I said, log files could contain useful information e.g. exceptions. I'd start with them.


Sorry, I haven't refreshed and therefore couldn't see your response. Ticket opened: https://youtrack.jetbrains.com/issue/GO-8226
Thank you.


Please sign in to leave a comment.