Win10, IntelliJ 2019.2.3, subversion via svn+ssh does not work

I think i have tested and configured every option which is discussed in the net but i cannot get IntelliiJ (2019.2.3) to work with svn+ssh. Whatever i do, i'm never prompted for a password nor IntelliJ uses the priv-key to authenticate. Nothing works, what happens when starting IntelliJ is:

Check out from Version Control --> Subversion --> [select svn+ssh://my.svn.host/reponame] --> Click on "Checkout" --> Select destination path --> Select correct destination path --> Select Working copy format (1.8, everything else is grey)

After that, the box with a progress bar appears and nothing more happens. It is there forever, and no communication to the server is done.

To me it seems the subversion support is completely broken somehow (which i never expected from IntelliJ).
Doing a "svn co svn+ssh://myusername@my.svn.host/reponame ." on command line works pretty well.

Btw, where to find the IntelliJ log file?

1
4 comments

Go to Help | Show log in Explorer, you can get the log.

 
0

ah thanks.    Looks like when svn prompts for the password, IntelliJ does not handle that somehow, regardless if "Interactive mode" is enabled or not. Last log entry is

Command output - Updating '.':

and then it hangs forever. Doing the command manually, svn prompts for the password and after typing it in, everything get updated and fine. But within IntelliJ it does not work.

Anyway, with help of the logfile i got keybased auth working with Tortoise svn and openssh ssh client. Everything else not.

 

Edit: Same behaviour on Linux. Only working with keybased auth.

1

I am having the same issue except with 2020.1.1. This is rather disappointing. There are many companies that still use SVN.

0

In 2020.1, this migth be an issue with Interactive mode - https://youtrack.jetbrains.com/issue/IDEA-236916

A workaround is to make ssh client to save credentials on its own, so that commands executed from the IDE would not prompt for passowrd.

0

Please sign in to leave a comment.