Debugger won´t work: Undefined method disable_all_iseqs in debase-0.3.0.beta8

Completed

Hi all!

I´m trying to make the RubyMine debugger work, but again and again I arrive at this error:

/Users/tom/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/debase-0.3.0.beta8/lib/debase.rb:71:in `start': undefined local variable or method `disable_all_iseqs' for Debase:Module (NameError)

That debase gem seems to be distributed with the Rubymine installation files. Anyone have an idea of what could be the solution? Thanks in advance!

32 comments
Comment actions Permalink

Warren's solution worked for me. Thanks mate. What a pain JetBrains

 had to delete all debase items in ~/.rbenv/versions/*.*.*(2.7.0 for me)/**/debase*. 

then ran

gem install --local /Applications/RubyMine.app/Contents/plugins/ruby/rb/gems/debase-0.3.0.beta34.gem -- --with-cflags="-Wno-error=implicit-function-declaration"

which required install of debase source first, so installed that.

and can now debug

0
Comment actions Permalink

I have tried many different versions 2020.1.4, 2020.2, 2020.2.4, 2020.3.2 but the issue is still there. It is frustrating. Warren's solution does not work for me. I'm on RHEL7.4 by the way.

0

Please sign in to leave a comment.