Deactivate skipping of colons when typing

When I edit code and the next character after the cursor is a colon, and I type a colon, PyCharm will not insert another colon but instead skip this character and set the cursor after the colon that was already there. Example: I already have the text "Code:123" and the cursor is behind the 'e'. I type "abc:456". Instead of "Codeabc:456:123" I get "Codeabc:456123".

How can I turn this off? I never ever want any editor to change what I type.I figure this is probably one of the autocorrection options but which one? I already deactivated the options related to brace and quote completion but I cannot find anything that sounds like it could cause what I see regarding colons.

 

Please sign in to leave a comment.