Push button is not available in Git Push window on 1920x1080 screen resolution



I cannot access 'Push' button in Git Push Window (Top Menu -> VCS -> Git -> Push) on 1920x1080 screen resolution and 125% scaling, Windows 10. Could you please add scroll functionality into this window?


Have you tried changing the scaling to 100%?


Yes, I tried 100% scaling, it works well, the push window fits neatly between the top and bottom of my screen, that's why I mentioned 125% scaling in the topic. Unfortunately I cannot use scaling less than 125% because of too small elements in this case, 15.6" monitor + 1920x1080 resolution + 100% scaling = broken eyes. I am sure scroll functionality can solve the problem in the this kind of IDE windows.        


Ah, as a workaround, you may shrink the push window in 100% scaling mode so that it can show normally in 125% scaling.


Thank you! I did that, almost has no effect,  the window is large enough because of many controls


Try disabling the Gerrit plugin, it seems the panel it adds to the dialog is causing the issue.


I use Gerrit Plugin, the repo is under Gerrit, so this window is not need for me without Gerrit


Gerrit is a third-party plugin, if it works fine without the plugin - please report the issue to the plugin author.

The issue might be related to the plugin not working correctly with the recent changes in the IDE.

Check if disabling the new UI decorations helps as a workaround.
1. Help | Edit Custom Properties
2. Add ide.win.frame.decoration=false
3. Restart IDE


Yes, this custom property solves this UI issue, I'll post issue for Gerrit plugin.
Thank you!


Please sign in to leave a comment.