Chinese/Japanese characters do not display correctly when "Anti Aliasing" is set to "Subpixel"

Answered

expected result:

while actually is:

however, when it is set to "Greyscale" the characters display normally in editor while IDE do not have these problems

the same thing also happens while using Japanese katakana

using Microsoft YaHei as custom font

quite sure that encoding settings were all set to UTF-8

 

0
2 comments

Please Add Installation info(found in About) and start up log(Found in Help | Show Log in Explorer) of idea.

 

And the screenshot of your Editor's Font Setting.

1

Problem solved, I didn't set the fallback font in Editor settings.

By default, it is set to "None".

Thank you for your help @Liu Peipei

0

Please sign in to leave a comment.