vmprof snapshot not loading

I'm using Idea Ultimate 2019.2.3 on Windows 64bit but using Python 3.7.4 32 bit and latest vmprof package

After the python program has completed I see this line in my console but Idea does not load the snapshot in the UI.

Snapshot saved to C:\Users\dmoldovan/.IntelliJIdea2019.2/system\snapshots\signature_cause.prof

Process finished with exit code 0

Any one else encountered this issue?

Thanks,

Daniel

 

5 comments
Comment actions Permalink

Can you please provide more detailed steps to reproduce the issue?

0
Comment actions Permalink

I see this as well.  If the vmprof package is installed, that's what pycharm uses.  The run console reports that the snapshot is being saved, but pycharm doesn't seem to load the results.

I don't think there's anything special about my configuration; my remote is a linux system and not windows.

Uninstalling vmprof and installing yappi works as expected.

0
Comment actions Permalink

Running this code is sufficient to demonstrate the issue:

import sys

if __name__ == "__main__":

    sys.exit(0)


This is run from a basic configuration using a script path (using a python module results in immediate exit regardless of profiler used).

0
Comment actions Permalink

That doesn't look like the same issue.  In my case, vmprof is run (not just the degenerate example above, but much longer runs as well).  However, on termination or on hitting the "snapshot" button, the vmprof stats are written on the remote, but never downloaded locally for display.

Manually retrieving the file and the opening via "Open CProfile snapshot" results in proper display of the profiling results.

0

Please sign in to leave a comment.