How to disable prettier errors in webstorm?

WebStorm Version: 2019.2.4.

The main reason to use prettier is to for the ease of formatting the code once you have written it. However, the entire code is littered with prettier-errors once I start coding. I want to disable prettier warnings. I tried disabling the plugin, but the problem still persists. Any suggestions?

2 comments
Comment actions Permalink

Prettier integration plugin, when enabled, only provides a Reformat with Prettier action + prettier code style import, it's not responsible for showing Prettier warnings in editor. You must be using ESlint+Prettier ( prettier-eslint , eslint-plugin-prettier)

To get rid of the linter errors, try disabling ESLint in Settings | Languages & Frameworks | JavaScript | Code Quality Tools | ESLint

3
Comment actions Permalink

It would be great if you could do this with the keyboard or menu item.  And receive an occasional reminder that you've turned it off.  Since you want it on, but in the initial stages of coding it gets in the way.  It doesn't help that IntelliJ / Webstorms default markers for this make prettier issues look like syntax errors.

-1

Please sign in to leave a comment.