Phpstorm unable to show special chars in run console

hi there,

i am a bug fan of https://github.com/kint-php/kint - which produces output like this:

but when u run phpunit via docker remote, the phpstorm console shows me this:

it has nothing todo with colors, when i use `~d(...)` i get the same results.
i also tried, as suggested, adding

-Dfile.encoding=UTF-8 

to the vm options, but this has no effect.

i would be very happy, if someone can help me here!

thanks a lot!

micha

 

5 comments
Comment actions Permalink

Looks fine for me on Linux: http://prntscr.com/pwihum
What OS are you using?
Would it be better if you start PhpStorm with the default settings? You can do that by temporary renaming idea.config.path: https://intellij-support.jetbrains.com/hc/en-us/articles/206544519

0
Comment actions Permalink

I use phpstorm (latest EAP) with windows. docker runs remote on a real Linux host. strange 🤔

0
Comment actions Permalink

Eugene Morozov which version are you using ? thanks.

0
Comment actions Permalink

Eugene Morozov yes, tested as suggested with default settings, still the same output ;-(

0
Comment actions Permalink

Let's continue this conversation in the issue: https://youtrack.jetbrains.com/issue/WI-49702

0

Please sign in to leave a comment.