Debugging flask with Docker compose interpreter force debug mode off

I followed this tutorial

https://blog.jetbrains.com/pycharm/2017/03/docker-compose-getting-flask-up-and-running/

 

And after a long time I was able to debug the application. The problem is when I want the application to restart when I make changes locally. The problem is when I want the application to restart when I make changes locally. Creo que el problema es el docker-compose que agrega PyCharm

/usr/local/bin/docker-compose -f $HOME//PyCharmProjects/flask-compose/docker-compose.yml -f $HOME/PyCharmProjects/flask-compose/docker-compose.dev.yml -f $HOME/.PyCharm2019.1/system/tmp/docker-compose.override.263.yml up --exit-code-from web --abort-on-container-exit web

 

This file has the environmental variable FLASK_DEBUG: "0", which overrides any environmental variable that I could set.

 

 

Do you have any idea how to solve this? This file is generated dynamically,

 

Thanks!

 

PD: I was not able to reach the endpoint unless I use the parameter

network_mode: "host"

 

in docker-compose.dev.yml. It may be the case that you have tu update the repo or it's just a problem in my computer?

Please sign in to leave a comment.