main menu not showing on ubuntu

The main menu (the one where the pulsants were View, File and other) doesn't apear and i don't know how to solve


Please check if you have main menu disabled in the settings. You can quickly do this by searching for "main menu" in "search everywhere" (double shift).

If this doesn't help, I suggest clean reinstall of PyCharm.


I have the same problem for IntelliJ Ulitmate.. I am on ubuntu 19.10.

I try re install, edit vmoptions, removing all option, switch Show Main menu to True.

Nothing changes..  love JetBrains, but this will force me to use another IDE :/

Ps : I saw the bar when intellij launch, then it disappear

Ps2 : I've set up shortcut to show main menu, but it isn't working too

EDIT : I can see the bar on FullScreen mode, when i put my mouse on top

I think it's just an options to set to true in vmoptions file.




Does it help if you disable key in Help | Find Action | Registry and restart IDE?


I have the same issue with WebStorm 2019.3.3 and Ubuntu 19.10 (Gnome). I've tried different parameters combination without luck.


Is it a screenshot from the full-screen mode?

See similar thread for other solutions


I had the same problem, but solved it by toggling global menu integration.  Get to search with shift shift.  Search for menu.  Then select Toggle Global Menu Integration.




Running Arch i3 here. Disabling `` worked for me after restarting the IDE.


Thank you Wdsmart. This got my menubar back within each window!


Please sign in to leave a comment.