Getting "ghost text" inside gutter

Once I click into the text editor, and navigate throughout the file, I will get "ghost text" inside the gutter that comes and goes. Anyone have any ideas on what might be causing this? Seem to show up in 2019.2 and persist in 2019.3. It does go away if I give focus to a different window or app.

 

You can see the ghosted text just to the right of the line numbers in the image below.

11 comments
Comment actions Permalink

can be related to https://youtrack.jetbrains.com/issue/IDEA-185487; can you share your idea.log (Help > Show Log in Explorer)? Do you have any external monitors attached?

0
Comment actions Permalink

It does seem similar, but I get the ghosting immediately and restarting doesn't seem to affect it. But I am using a multiple monitor setup, PC is a laptop on a docking stations and then two external monitors attached. (So total of 3 screens). Running Webstorm on one of the attached monitors. 

I cleared the log, started WS, clicked around the file a couple times, and closed WS. I did removed lines that duplicated several times and indicated it with an approximate of how many times it displayed. (Let me know if this breaks a parse for you).

Example: the below line was repeated 10 times, so I marked it and only left it in once to reduce the log.

com.intellij.ide.ui.UISettings - Loaded: fontSize=12, fontScale=1.0; restored: fontSize=12, fontScale=1.0  x 10!!!!!

 

 
2019-11-26 09:27:08,476 [ 276] INFO - #com.intellij.idea.Main - IDE: WebStorm (build #WS-193.5233.80, 25 Nov 2019 03:59)
2019-11-26 09:27:08,486 [ 286] INFO - #com.intellij.idea.Main - OS: Windows 10 (10.0, amd64)
2019-11-26 09:27:08,486 [ 286] INFO - #com.intellij.idea.Main - JRE: 11.0.4+10-b520.11 (JetBrains s.r.o)
2019-11-26 09:27:08,486 [ 286] INFO - #com.intellij.idea.Main - JVM: 11.0.4+10-b520.11 (OpenJDK 64-Bit Server VM)
[ removed for thread readability]

0
Comment actions Permalink

Note: Un-docking the laptop (so no external monitors) produces the same results. 

0
Comment actions Permalink

what is your current main monitor configuration (resolution, scale factor)?

0
Comment actions Permalink

100%
1920 x 1080

Landscape

0
Comment actions Permalink

can't reproduce with similar setup... Must be specific to your PC configuration (video cards/drivers etc)

0
Comment actions Permalink

Can you check if the issue persists after switching to a different JDK? You can try the IDE build with JRE 8 bundled (https://www.jetbrains.com/webstorm/download/other.html), or switch to Oracle JDK... See https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

0
Comment actions Permalink
Switching to Oracle JDK did not seem to make a difference. 
 
2019-11-26 10:55:37,855 [    139]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_201-b09 (Oracle Corporation)
 
 
0
Comment actions Permalink

By turning off the previously set Background color in File > Settings > Editor > Color Scheme > General > Gutter backgound, I no longer see the ghosted text. If I set a color I can again see the ghosting.

I'm guessing something is still happening under the hood... but I no longer see it, so I am good with it :)

 

Appreciate all your time today.

0

Please sign in to leave a comment.