yarn: command not found

Answered

Hi everyone,

I have a new issue since I updated rails gem from 5.2.3 to 6.0.1

When I try to run rails in development mode with the navbar (top right) it just doesn't work, I have the following message :

/usr/bin/ruby /home/flo/Ruby/updatedRailsTest/bin/rails server -b 0.0.0.0 -p 3000 -e development
=> Booting Puma
=> Rails 6.0.1 application starting in development
=> Run `rails server --help` for more startup options
sh: yarn: command not found

========================================
Your Yarn packages are out of date!
Please run `yarn install --check-files` to update.
========================================


To disable this check, please change `check_yarn_integrity`
to `false` in your webpacker config file (config/webpacker.yml).

With some research on similar issue I found that is probably a PATH issue and I tried multiple fix but it doesn't work...

Because if I run "rails s" or "bundle exec rails s" or "yarn" in a normal terminal (or the embeded terminal in bottom of jetbrains IDE) there is no issues, but with the navbar it doesn't work

Best regards

N.B. sorry for my english, i'm french

4 comments
Comment actions Permalink

Hello Florent,

just to be sure, in case you launch RubyMine from the terminal does it work?

0
Comment actions Permalink

Hello,

I launched RubyMine via desktop shortcut (the script run a command like Exec="path_to/rubymine.sh"), but I solved the issue by running "sudo npm i -g yarn" I know that it's not a good practice to install npm package with sudo but for the moment it's ok for me.

 

0
Comment actions Permalink

I have the same problem...

There is another solution?

1
Comment actions Permalink

exact same problem...

0

Please sign in to leave a comment.