2019.3 on Mac Catalina: CPU Usage

When I launch the application, a modest document of 1,500 lines can be scrolled smoothly.

After around 10 minutes of usage, however, I notice that the document is scrolling in a very jerky way, with visible lag.

Opening up the Activity Monitor, I see PhpStorm idling at 0.5% CPU.  If I then scroll the page, I see it jump to 100% CPU usage.

Clearly something has happened since the previous release and this one, performance is visibly worse.

13 comments
Comment actions Permalink

Could you please try disabling Appearance & Behavior | Appearance | Smooth scrolling option? Does it help?

2
Comment actions Permalink

Yes, that solved the problem, but prior to this version smooth scrolling never caused any slowdown.

0
Comment actions Permalink

I have the same problem, but disabling smooth scrolling does not solve it.

 

2
Comment actions Permalink

I have the same problem, downgrading to 2019.2 solved this problem.

0
Comment actions Permalink

I've had same issue with PyCharm v.2019.3 on macOS Mojave v.10.14.5.
Disabling smooth scrolling didn't solve issue.
Installed v.2019.2 few hours ago and seems to be fine now.

0
Comment actions Permalink

To expand on my previous reply, and in agreement with the above, turning off smooth scrolling only helps a little, it doesn't completely solve the problem.  Smooth scrolling just happens to make it considerably worse.

The problem didn't exist in the previous version, and it needs to be resolved.

0
Comment actions Permalink

FWIW, this affected me w/ 2019.3.1 on macOS Catalina and a Magic Mouse, disabling smooth scrolling helped and so did this:

"New behavior can be just turned off with option idea.inertia.smooth.scrolling.enabled via Help -> Edit Custom Properties or tuned with"

still not perfect, but it's much more responsive.

0
Comment actions Permalink

It's not a problem with the scroll, I have the scroll issue on 2019.3 and 2020.1 BETA, but only starts lagging after a short while, the cpu usage skyrockets and even the keyboard inputs are sluggish. Feels to me like it's a rendering issue, almost like a framerate drop in a videogame.

0
Comment actions Permalink

It's antialiasing and smooth scrolling.. 

1
Comment actions Permalink

I still have jitter problem on the 2020.1 version and newest macOS.

it's like in the old dos days when there was an interrupt problem.

it's really painful to have this in the year 2020.

I cannot work like this.

turning off anti aliasing and smooth scroll does not change a thing

0
Comment actions Permalink

Nick Winger, it's pretty useless to complain about performance issues on the community forums, as cases are usually different and require troubleshooting information collected separately.

Please submit your logs (Help | Collect Logs and Diagnostic Data) within a support ticket (Help | Contact Support), we'll take a look.

0
Comment actions Permalink

Turning off both anti aliasing and smooth scrolling solved this for me as Lawrencealan indicated.

I wonder if the Intellij team perf tests new features on all platforms before releasing a version.

1

Please sign in to leave a comment.